5

I'm facing a problem that LDAP authentication for ImportExportService(Content Porter) doesn't work. I have already configured LDAP authentication for TCM, so I can log in TCM.

When I login to Content Porter, Content Porter client say the following message.

Could not find SDL Tridion Content Manager server myservername. Please verify that the server is up and running.

And the following message is output to event log.

Access is denied for the user NT AUTHORITY\NETWORK SERVICE.

Component: Tridion.ContentManager.ImportExport Errorcode: 770 User: NT AUTHORITY\NETWORK SERVICE

StackTrace Information Details: at Tridion.ContentManager.Security.AuthorizationManager.LoadAccessToken(String userName, IEnumerable1 mappedGroupUris, IEnumerable1 claimSets) at Tridion.ContentManager.Session..ctor() at Tridion.ContentManager.CoreService.SessionHelper.GetCurrentSession() at Tridion.ContentManager.ImportExport.Service.ImportExportServiceBase.TestConnection() at SyncInvokeTestConnection(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

I tried two pattern setting of webservices/web.config as follows, but I couldn't login.

CASE A

   <binding name="ImportExport_StreamDownload_basicHttpBinding" maxReceivedMessageSize="2147483648" transferMode="StreamedResponse" messageEncoding="Mtom" sendTimeout="00:30:00">
     <security mode="TransportCredentialOnly">
       <!-- For LDAP or SSO authentication of transport credentials, use clientCredentialType="None" -->
       <transport clientCredentialType="Windows" />
     </security>
   </binding>

CASE B (clientCredentialType was set to None)

   <binding name="ImportExport_StreamDownload_basicHttpBinding" maxReceivedMessageSize="2147483648" transferMode="StreamedResponse" messageEncoding="Mtom" sendTimeout="00:30:00">
     <security mode="TransportCredentialOnly">
       <!-- For LDAP or SSO authentication of transport credentials, use clientCredentialType="None" -->
       <transport clientCredentialType="None" />
     </security>
   </binding>

Could you please tell me what I should do?

Environment: Tridion 2013 SP1 Content Porter 2013 SP1 Windows 2008 R2 SP1 + MSSQL 2008 R2 SP2

Regards

  • I am also facing similar problem even though everything has configure as required in this post. Anyone have any solution on this issue? – Vivek Kwatra Aug 26 '14 at 5:56
2

Did you configure the steps needed for Content Porter configuration with LDAP? Please check the Tridion docs and follow these steps : http://sdllivecontent.sdl.com/LiveContent/content/en-US/SDL%20Content%20Porter%20full%20documentation-v1/GUID-3AB5898C-743B-4B4B-BE8B-46F1C0CDD300

Please note, these are additional steps needed for Content Porter in addition to the CM so you need to first make sure CMS UI working correctly with LDAP and then follow these steps for Content Porter.

| improve this answer | |
  • Thank you for your quick reply. I have already finished Content Porter configuration with LDAP. I have enabled anonymous access on the ImportExportService and ImportExportService\client virtual directories. SDL Tridion Content Manager configuration have been configured for using LDAP, so Impersonation User setting have been already set to 'Directory Service'. Regarding Urls without HTTP authentication, New value '|(ImportExportService/Client)' have been set when I installed Content Porter 2013 SP1. Do I have anything to check? – Masakazu Ohtsubo Jun 6 '14 at 0:01
2

Since 2013 SP1 Content Porter Core part is placed in Tridion Core (TcmServiceHost + IIS). Your stack trace shows, that there is problem on creating session (impersonation). Look here http://sdllivecontent.sdl.com/LiveContent/content/en-US/SDL%20Tridion%20full%20documentation-v1/GUID-20723F2E-686D-44AC-835A-8F84A5DD7A22#url=/LiveContent/web/search.xql%3Fc%3Dt%26pub%3DSDL+Tridion+full+documentation-v1%26lang%3Den-US%26action%3Dsearch%26query%3DLDAP&sid=lcSearch.runSearch1395735753185&currentQuery=LDAP&currentScope=&eventType=lcContent.loadDocGUID-5EF9CE54-A864-4CE2-A61C-9F7DF97902B3&query=&scope=&filename=GUID-5EF9CE54-A864-4CE2-A61C-9F7DF97902B3.xml

PS: usually problems with CP connection were related to 8D. Earlier this point was missed in the documentation

PPS: Looked again...There are can be additional problems with configuration of CP. But for now your problem is simpler - CoreService is not working with LDAP Authentication.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.