4

I am trying to run the DD4T template installer on a development Tridion environment. The installer always errors our though with a Error 1001. The error is about a transaction not getting committed.

Here is the error details

Product: DD4T Templates -- Error 1001. Error 1001. Unable to upload the DD4T Templates into SDL Tridion. Please verify your input. Additional info: Exitcode: 1. Output from TcmUploadAssembly: Info: Using URL 'http://myserver/templating/AssemblyTemplateUploadWebService.asmx' Info: Logging in as Administrator Error: The transaction associated with the current connection has completed but has not been disposed. The transaction must be disposed before the connection can be used to execute SQL statements.

at[remote] System.Data.SqlClient.TdsParser.TdsExecuteRPC(...) at[remote] System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(...) at[remote] System.Data.SqlClient.SqlCommand.RunExecuteReader(...) at[remote] System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(...) at[remote] System.Data.SqlClient.SqlCommand.ExecuteNonQuery(...) at[remote] Tridion.ContentManager.Data.AdoNet.DatabaseUtilities.ExecuteNonQuery(...) at[remote] Tridion.ContentManager.Data.AdoNet.Sql.SqlDatabaseUtilities.ExecuteNonQuery(...) at[remote] Tridion.ContentManager.Data.AdoNet.ContentManagement.VersionedItemDataMapper.Tridion.ContentManager.Data.ContentManagement.IVersionedItemDataMapper.RevisionApplicationData(...) at[remote] Tridion.ContentManager.ContentManagement.VersionedItem.OnCheckedIn(...) at[remote] Tridion.ContentManager.ContentManagement.VersionedItem.CheckIn(...) at[remote] Tridion.ContentManager.ContentManagement.VersionedItem.Save(...) at[remote] Tridion.ContentManager.Templating.Templates.SetupDefaultTemplates.CreateParametersSchema(...) at[remote] Tridion.ContentManager.Templating.Assembly.DotNetTemplate.SetParametersSchema(...) at[remote] Tridion.ContentManager.Templating.Assembly.TemplateAssemblyStorage.StoreTemplateAssembly(...) at[remote] Tridion.ContentManager.Templating.Assembly.TemplateAssemblyStorage.PerformStoreTemplateAssembly(...) at[remote] Tridion.ContentManager.Templating.WebService.AssemblyTemplateUploadWebService.PerformStoreTemplateAssembly(...) at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Tridion.ContentManager.Templating.UI.UploadAssembly.WebService.AssemblyTemplateUploadWebService.PerformStoreTemplateAssembly(Byte[] assemblyContents, Byte[] pdbContents, String assemblyFileName, String targetFolder) at Tridion.ContentManager.Templating.UI.UploadAssembly.AssemblyStorageClient.PerformStoreTemplateAssembly(String webServiceUrl, String userName, String password, String overrideFolder, Byte[] assemblyContents, Byte[] pdbContents, String assemblyFileName) at Tridion.ContentManager.Templating.UI.UploadAssembly.AssemblyStorageClient.UploadAssembly(String assemblyPath) at Tridion.ContentManager.Templating.UI.UploadAssembly.AssemblyStorageClient.Main(String[] args)

(NULL) (NULL) (NULL) (NULL) (NULL)

the message resource is present but the message is not found in the string/message table

Any idea what is causing this and how I can get this to work so I can get DD4T installed?

  • hey, is it resolved? – Raj Kumar Jun 17 '14 at 13:25
3

I seems to resolved it. This issues happens in the scenario when the CM database is being restored from some other environment. Also, this applies to not only installing the DD4T TBBs but also for any Custom TBBs referring the DD4T TBBs.

Resolution:

  • Open the Tridion CM database in SQL Server Management Studio
  • Locate the table - Queue_Consumer and open it in edit mode
  • Mark status of all other hosts from online to offline - you need to update the field value IS_ONLINE to 0 for all hosts other than your current host machine.

    enter image description here

| improve this answer | |
1

In your problem: TcmUploadAssembly is unable to upload the templates into CM.

Please make sure following are correct

  1. Username & Password (try admin, mts user)
  2. CME URL
  3. Folder URI (where you want to upload the dll)
  4. TcmUploadassembly tool's Version.(FYI: generally it should be correct as it will be picked from "bin\client\")

if above correct it could be transaction timeout problem: you can try following different possible solutions

| improve this answer | |
  • Not sure what you mean by #4. I tried this on another machine and it worked fine. #1-3 are correct. – ToddB Jun 13 '14 at 13:26
  • i have updated my answer. – Raj Kumar Jun 13 '14 at 20:38
  • It is not. I am having this issue with a sandbox environment. I tried to install it in our real dev environment and it worked so I am assuming something messed up with the sandbox install. – ToddB Jun 17 '14 at 20:29
0

I had this error - but only if I was running the installer directly on the Tridion server itself.

When I ran in from my laptop it worked fine!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.