5

While exporting content through Content Porter, I am getting the below mentioned error:

[Error] Tridion.ContentManager.ImportExport.ImportExportException: 
Application data with application id 'ugc:ComponentAndPage' of the item 
'/webdav/000%20Root/Building%20Blocks/demo/myImage.jpg' cannot be parsed. ---> 
System.Xml.XmlException: Root element is missing.

This Image component is created using "Default Multimedia Schema", there are other components of same schema which are getting exported in the package.

enter image description here

Environment: Windows Server 2008 R2, Tridion 2013 SP1, Content Porter logged in with Administrator account (same windows login account)

Is there any way, where this component can be corrected (without creating a similar new component and deleting the old)? info: Schema has been verified - it is fine.

  • 1
    Schema is fine you said as it is verified; is the component has also been verified? Can you open the component, Save & Close it successfully and then retry import/export – Pankaj Gaur Jul 2 '14 at 12:34
  • It seems issue with its component related to this multimedia component, see the error "ugc:ComponentandPage", Its looks like related to UserGeneratedContent. it could be issue with installation of ugc on destination machine. – Raj Kumar Jul 2 '14 at 12:46
  • Can you read applicationData for item "/webdav/000%20Root/Building%20Blocks/demo/myImage.jpg" with applicationId "ugc:ComponentAndPage"? During exporting of the appdata, for ugc items it must be converted to XmlDocument...In your case it can not be parsed. – Syav4eg Jul 2 '14 at 14:26
  • 1
    @Pankaj: yes.. component has also been verified, all components of that schema have been checked.. but this issue is there with only a few components (total 3)... Syav4eg : How to read applicationData for any item?? – Saurabh Mehndiratta Jul 2 '14 at 14:42
  • 1
    a bit drastic but maybe backup the CM DB and then try to delete the AppData ugc:ComponentAndPage for these failing items. – Philippe Conil Jul 3 '14 at 22:01
3

I ran into this problem today. In my case, I was selecting the application data category "User Generated Content." or as referenced in the error, ugcComponentAndPage. I did not need to select this category for my export. So, I went through the content porter export steps again, this time not selecting user Generated Content and my export completed without errors. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.