9

I've encountered a licence error with Tridion 2013 (Build 7.0.0.568). When navigating to the CME, I'm taken to the dashboard and rewarded with an error:

System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. --->

Tridion.Web.UI.Core.Common.LicensingUtilitiesException: Can't create TDSXGit.Configuration at Tridion.Web.UI.Core.Common.LicensingUtilities.CheckLicense() at Tridion.Web.UI.Controls.TridionPage.OnPreLoad(EventArgs e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

I've reinstalled the licences, deleted a lock file, restarted com+, IIS, all Tridion services and even rebooted the entire operating system.

The windows event log also has a copy of the error, but contains no extra detail other than "Is authenticated: True".

Anyone else had this or got any suggestions on how it might be resolved?

  • 1
    Saw it once on Tridion 2009. Windows User (too lazy to figure it out :), probably the user running the Tridion AppPool) did not have enough rights on the Tridion install folder (Especially the 'bin' folder). 'Solved' it by giving Everyone full control. I know. Really, I do. – Albert Romkes Jul 2 '14 at 17:28
  • The odd thing is that this instance did work but has simply 'stopped'. Perhaps a Windows update has interfered with a permission / ownership of something. I tried putting an 'old' licence in place and as expected I get a "Licence has expired" message, then put the correct licence back in and I'm back to the above error. Albert, I also tried giving Everyone, Full Access and that also doesn't solve the problem. – Mark Sizer Jul 2 '14 at 19:09
  • Use fiddler or similar, to identify which file(s) are trying to be read and which ones are unaccessible. Just out of curiosity, does your MTSUser and your Administrator user have the appropriate rights? – Jaime Santos Alcón Jul 2 '14 at 20:33
1

What are the COM+ and impersonation users running? This is very likely a permission issue for either of the two accounts in need to be able to access the Tridion.ContentManager.config file (the "Git" in the error message stands out), which is encrypted. So this is about either access to the file itself, or access to the folders containing it. To allow a(nother) user access to the encryption key, follow the steps in this article. http://tridion.kb.sdl.com/kb/?ArticleId=3751&source=Article&c=12&cid=19#tab:homeTab:crumb:7:artId:3751

| improve this answer | |
  • Thanks for the response. However I no longer have access to the system that was exhibiting this problem and therefore cannot say if it helps or not. I've up marked the answer as it is the best anyone has offered in six months. I'll mark it as the accepted answer if someone else has the problem and confirms this resolves it. – Mark Sizer Jan 2 '15 at 12:06
1

I had the same issue after removing 'old' accounts from the server. The Content Manager snap-in was also unavailable, so this article pointed me in the right direction: https://stackoverflow.com/questions/10017972/content-manager-configuration-snap-in-could-not-read-configuration-item.

I think I removed the account which ran the installer. My solution:

Run the installer again (SDLTridion2013SP1CM.exe in my case) and choose the repair option. This fixed the issue (after reboot).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.