I am using SDL Tridion 2011 SP1, and facing issue in Tridion's Search Functionality.

When I try to use Advance Search in Content Manager Explorer for certain criteria (like Date Modified and Author), it does return me some result...but this list is not complete and I can see more items satisfying the criteria when I navigate to individual folders and see their history for the current version (I have chosen to show all matching results and even tried changing the value to 50 and 100 records as my total results are very much less than 50).

I have search for known issue but I could not get anything more than as specified.

1) Am I missing any additional configuration/hotfix or anything like it? - Can some one help me with it

2) Is it a known issue with Content Manager Explorer and the above said document set is not updated? - Please let me know if there is any hotfix available for the same OR

3) It is not at all reported by anybody yet?

Please note: I have faced the similar issue in SDL Tridion 2009 as well as in SDL Tridion 2009 SP1 (where Virtual Folders does not give expected result) and Tridion Support has suggested it as a known issue. I was anticipating that it would get fixed in 2011 or 2011 SP1 at least

3 Answers 3


Try accessing the local Solr interface (e.g. http://localhost:8983/tridion). You can use the search box there to check if the items have been indexed.

Specifying *:* will return all items. It only returns a limited set of fields, including ID. Do you see the items you want listed in the results here?

If you don't see them there, then they haven't been indexed. When you ran the reindex, did it complete without errors?

You can also look in the solr logs for errors - probably something like $TRIDION$\log\2013_03_25.jetty.log.

  • Thanks oic and Rob for your help. It looks like a re-indexing issue indeed. Earlier re-indexing seems does not finished properly. there were some vague errors in the Log and querying on SOLR also does not returned the expected result. Did re-indexing again and ensured that it completes without errors, and now I see all expected results. Thanks for all your help Commented Mar 26, 2013 at 6:06

This was one of the reasons why Tridion 2011 moved to an implementation of Lucene & SOLR (indexing issues with Verity).

Is there any additional detail you can provide as to the type of data missing in the results? Is it always content of a given type (multimedia or schema or folder). Is it content created on a given date?

Also, how is your CM structured? Are you running on a single CM machine of multiple? There are additional steps required (login required) when configuring search across multiple servers.

  • 1
    Thanks Nuno...I understand this reason of moving to SOLR from verity being a pro in SOLR. By the way, I am working only with Components and Pages and generally it is happening with both of them. Further I am working on a Single CM machine environment Commented Mar 25, 2013 at 9:48
  • Thanks for the update Pankaj. As Nuno mentioned, do you have a little bit more information about the missing items. For example, Are they new or old items that are missing? Are they created in the Publication that you are searching in? Is it only for a particular content type (Schema)? Are you searching for a particular keyword? Thanks, Commented Mar 25, 2013 at 11:49
  • Specifically I am doing following: 1) Searching in ALL Publications 2) Searching Items modified in a particular Date range and by a specific Author I am not sure what do you mean by old or new item, but they recently modified items. Not searching for any Keyword Commented Mar 25, 2013 at 12:39

Have you tried reindexing as described here? http://sdllivecontent.sdl.com/LiveContent/web/pub.xql?action=home&pub=SDL_Tridion_2011_SPONE&lang=en-US#url=/LiveContent/web/search.xql%3Fc%3Dt%26pub%3DSDL_Tridion_2011_SPONE%26lang%3Den-US%26action%3Dsearch%26query%3Dsearching&sid=lcSearch.runSearch1364193286197&currentQuery=searching&currentScope=&eventType=lcContent.loadDoctask_362FC04056E04C28B60446031B93A078&query=&scope=&filename=ConfiguringSearchAfterUpgrade.xml&docid=task_362FC04056E04C28B60446031B93A078&inner_id=&tid=&addHistory=true&resource=

Basically run


I'd probably do this on a dev server first if you have one available as this could take a while with a large Content Manager database

  • Yes in Desperation I did but to no help. Also, this is pretty much new system (not older than one month) and the search functionality is not commonly used in this system. In fact, with in the context of publication, this was the first time, search functionality was used. On the other note, Thanks for your suggestion Rob, it will help others a lot :) Commented Mar 25, 2013 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.