4

I'm trying to upload a workflow with an external activity. My assebly TBB is uploaded intoa folder and now I'm trying to save my Visio flow into Tridion. However when I click the "save to tridion" button I get an error:

Could not load file or assembly 'Tridion.ContentManager.CoreService.Workflow'...

Here is a screenshot of the full error:

enter image description here

-- UPDATE --

I've checked the WF service is running as well as the WFListener website and its connection pool.

-- end update --

I've googled around and found this answer to what looks like a similar problem: TcmUploadAssembly tool throws error while uploading dll. Does this mean that the Tridion.ContentManager.CoreService.Workflow need to be added to the GAC, or is there something else that I've missed?

My External Activity script is as follows:

AssemblyTbbId="/webdav/100%20Schemas/Building%20Blocks/System/Workflow%20Assembly.tbbasm" Type="TestWorkflow.PublishStagingActivity"
  • 1
    Have you considered using fuslogvw to see how it's trying to load your assembly? – Dominic Cronin Jul 12 '14 at 13:08
  • As already was mentioned - use Fuslog. Also, can you clarify - what version of Tridion do you use? And is it fresh install, or upgrade ? – Syav4eg Jul 12 '14 at 13:32
  • Electridion 2013 SP1 VM – Nickoli Roussakov Jul 12 '14 at 16:45
2

It is hardly to analyze, why this has happened without understanding of the context, but partially I know "WHY" and even can suggest a workaround.

Your external activity (uploaded to assembly template with Id = AssemblyTbbId) is built against Tridion 2013 (major version 7.0). You are using Tridion 2013 SP1 (major version of the assemblies 7.1) and Tridion.ContentManager.CoreService.Workflow of the version 7.0 is not found (your External Activity implementation uses this assembly). During the saving of the TPD Tridion validates all its activity definitions for validating scripts (so to find all possible problems on the saving stage, but not during WorkFlow Agent executions). So Tridion just tries to create assembly from "AssemblyTbbId" and find "Type" in it. But assembly can not be created, because assembly against which is built your extension not found!

Why does it happened - additional question. We knew, that possible we can get such problems and Tridion 7.1 in the GAC has 2 assemblies of the Tridion.ContentManager.CoreService.Workflow (from 7.0 and 7.1). So idea is next - deliver each release this assembly since 7.0. So if you had extension built in earlier releases - it must work in the current one (so it will be interesting to know, how you've got this situation - upgrade, just took extension build in earlier versions, etc. Also inetersting what version of this assembly is presented in the GAC).

I've mentioned about workaround. If you have your project for external activity - just rebuild it against 7.1 and reload assembly to your TBB. After that, during saving of the TPD Tridion will be able to load your extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.