3

I am using the Tridion OData service to consume some data from a content-delivery database.

When I fetch a list of pages using odata.svc/pages, it is returning results in the browser. But when I publish any new page, it is not getting reflected in the results.

If I publish some new keywords, it's getting reflected.

I have checked cd_storage_conf and everything seems configured properly except that object cache is set to true (though I have got the server restarted). I have checked the content delivery database as well and the pages are getting reflected in the database.

Is it possible because of some deployer configuration setting?

  • Are HttpUpload and Odata Service referring same broker db & settings? – Raj Kumar Jul 15 '14 at 17:19
  • I didn't notice that odata service was set to return only 25 records. and hence it was returning only the top 25 records. – rdhaundiyal Jul 17 '14 at 3:50
  • @rdhaundiyal, great find. You can answer your own question and maybe add a little detail like how you changes that limit of 25 items. – Jan H Jul 18 '14 at 10:35
  • @Jan H, I didn't find this out as I was not having access to server but I will add the details :) – rdhaundiyal Jul 18 '14 at 14:56
5

This suggests that your Cache is enabled in the OData Web Service, but you didn't configure the Cache Channel Service, which is required for notifications to flow from the deployer to the web application(s).

See this section (login required) of the Documentation for details on how to configure cache synchronization. If this is just a dev machine, you could also consider disabling cache (in cd_storage_conf.xml).

| improve this answer | |
  • But in that case it should not reflect keywords as well. I am able to retrieve newly published keywords – rdhaundiyal Jul 15 '14 at 18:22
  • Maybe the cache implementation for Keywords is not working? If restarting your app shows the right results for pages, then it's clearly a cache issue. You could just turn cache off, and try it again? – Nuno Linhares Jul 15 '14 at 18:41
  • Thanks Nuno, I have tried turning off the object cache but its still not working. Is there anything we are missing in odata configuration which is causing the problem. – rdhaundiyal Jul 16 '14 at 5:43
  • That's weird, I certainly don't have that problem. Is it the same thing if you request /Pages in a browser? Maybe your client is caching the results? – Nuno Linhares Jul 16 '14 at 9:57
0

One of my colleague find out that maximum limit of records set to be retrieved was set to 25. In cd_webservice_conf of Odata deployment directory we increased the limit and it start displaying the results

<OData>
        <DefaultTop>25</DefaultTop>

 </OData>

PS. Filter parameter should be sent to odata service so that it will fetch only required records

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.