9

An issue has just starting occurring on one of our production CMS servers. We have an ECL MountPoint configured in our 'Schemas' Publication which get shared down to all publications. This has been working flawlessly for the last few months.

Yesterday, we stopped being able to browse any of the publications (Schemas Publication downwards) with the CME, and an error is raised in the message center and the event viewer pointing to a unique name constraint. The offending item is the Stub Schema in the folder defined by the Mount Point.

Has anyone else seen this issue? Any help greatly appreciated.

UPDATE: As this was urgent, I went ahead and tried some triage:

  1. I removed the MountPoint from the ExternalContentLibraries.xml and restarted the Service Host. This allowed me to access the CME again.
  2. I tried to delete all the stub components (they are not yet being used by other components)
  3. Some of the items were localized (under what circumstances does an ECL stub get localized, and how can you prevent it?)
  4. I un-localized the remaining items and deleted the parents (so there were no stub components
  5. I added the Mount Point back and restarted the service host

BANG! no access to publications in the CME again.

  1. Removed the Mount Point again
  2. Deleted the Stub Schema from the configured folder and added MP back again and restart services

BINGO! the stub schema was recreated and everything works again.

So it seems like for some reason the ECL framework had lost track of my schema, and was trying to re-create it. Any idea how this can happen? I am worried this could happen again when we are no longer in a position to delete the stubs and the offending schema.

  • I did not see this issue before. I did see ECL recreting the schema if I removed it. I think stub components can be localized when changing the Tridion metadata on the ECL item. Did you specify metadata fields in your stub schema? – Jan H Jul 30 '14 at 7:48
  • Just localizing the Schema (or changing it for that matter) won't be an issue, but deleting it and manually recreating it will, since then you would loose the AppData which was there. See Yuri's answer for details! – Bart Koopman Jul 30 '14 at 16:18
5

ECL keeps track of Stub Schemas by AppData attached to the Schema

The AppData name starts with ecl:stubschema

Apparently this AppData was deleted somehow and therefore ECL lost track and tried to recreate the Schema causing the issues you describe.

| improve this answer | |
  • 1
    I think you nailed it @Yuri, it is possible someone ported the Schema without the AppData – Chris Summers Jul 30 '14 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.