We have 2 CDA websites (publication targets), Preview and Live.

As per the question here, we should have single DB for XPM and Preview Broker. I have HTTPUpload WebService (deployed in IIS as a website) - for preview, where I have deployed odata.svc as well - to reduce the number of IIS web services.

Below is the storages configuration in cd_storage.conf file on my preview cum experience manager website/web-service:

    <Wrapper Name="SessionWrapper">
    <Storage Id="sessionDB" Class="com.tridion.storage.persistence.JPADAOFactory" Type="persistence" dialect="MSSQL">
    <Pool Type="jdbc" Size="5" MonitorInterval="60" IdleTimeout="120" CheckoutTimeout="120" />
    <DataSource Class="com.microsoft.sqlserver.jdbc.SQLServerDataSource">
        <Property Name="serverName" Value="MYDBSERVERNAME" />
        <Property Name="portNumber" Value="1433" />
        <Property Name="databaseName" Value="Tridion_ExperienceManager_Dev" />
        <Property Name="user" Value="adminUser" />
        <Property Name="password" Value="adminPass" />
    <Storage Type="persistence" Id="defaultdb" dialect="MSSQL" Class="com.tridion.storage.persistence.JPADAOFactory">
    <Pool Type="jdbc" Size="5" MonitorInterval="60" IdleTimeout="120" CheckoutTimeout="120"/>
    <DataSource Class="com.microsoft.sqlserver.jdbc.SQLServerDataSource">
        <Property Name="serverName" Value="MYDBSERVERNAME"/>
        <Property Name="portNumber" Value="1433"/>
        <Property Name="databaseName" Value="Tridion_ExperienceManager_Dev"/>
        <Property Name="user" Value="adminUser"/>
        <Property Name="password" Value="adminPass"/>

Please let me know if this is correct.

However, XPM and publishing to preview is working fine.

Also let me know where do we use "sessionDB" - coz at present, its not being used anywhere.


  • I'm not sure what is the question here. Is it "where is the Session DB used?"
    – Nuno Linhares
    Commented Aug 6, 2014 at 11:17
  • I took it the other way, that Staging website needs only 1 DB- that will be used as Preview broker and XPM. However, it is now clear that odata needs to have a separate DB. In the configuration file, this sessionDB entry is not being used anywhere. Any idea if I am missing any configuration? Commented Aug 6, 2014 at 12:11
  • OData should use the Session DB both as Wrapper and Storage. Website (staging) should use SessionDB as Wrapper only.
    – Nuno Linhares
    Commented Aug 6, 2014 at 12:49
  • is it resolved now?
    – Raj Kumar
    Commented Aug 7, 2014 at 7:54
  • @Nuno, what do you mean OData should youse session DB for storage? I thought OData should use the same DB for storage as the website/deployer... Commented Aug 8, 2014 at 11:16

2 Answers 2


Your "preview" (staging) site indeed requires two databases - one broker, one sessionDB. Your live site requires only one (just the broker). You should configure the sessionDB in the datasource inside of the sessionwrapper, the broker DB in its normal place below.

  • I have asked the question - how many number of DBs are required for XPM and preview, tridion.stackexchange.com/questions/7252/…, where it was answered that we should use XPM and Preview DB as same. Please have a look. Commented Aug 6, 2014 at 10:48
  • 1
    Saurabh, when I read the answers to your question there, they do tell you you need two databases to support an XPM site: one broker and one preview. Commented Aug 6, 2014 at 10:50
  • 1
    That's the same I read - and indeed you need 2 different databases.
    – Nuno Linhares
    Commented Aug 6, 2014 at 11:16

as i answered in your previous questions On Staging you need two Separate Databases.

  • 1) Exclusively for odataService, (Session-db)
  • 2) For Staging website.

So create a separate db. and update above give configuration. Is your preview working fine?

just want to give more clarifications.

There would be two different IIS application

  • 1 for oData for
  • 2 for your staging website. (there would be some setting in website's config as well)

you can refer documentation (require login)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.