3

We are facing an issue while trying to port our schemas from one environment to another. Porting of components is working fine and we are not getting any error. Below is the error that we are getting in content porter log

     <tcm:Error ErrorCode="8004033F" Category="4" Source="Kernel" Severity="1" xmlns:tcm="http://www.tridion.com/ContentManager/5.0"><tcm:Line ErrorCode="8004033F" Cause="false" MessageID="16137"><![CDATA[Unable to save Publication (tcm:0-28-1).]]><tcm:Token>RESID_4574</tcm:Token><tcm:Token>RESID_4452</tcm:Token><tcm:Token>tcm:0-28-1</tcm:Token></tcm:Line>
<tcm:Line ErrorCode="8004033F" Cause="true"><![CDATA[ORA-01013: user requested cancel of current operation
ORA-06512: at "TCMDBUSER.EDA_PUBLICATIONS", line 5261
ORA-06512: at "TCMDBUSER.EDA_PUBLICATIONS", line 4205
ORA-06512: at line 1]]></tcm:Line>
<tcm:Line ErrorCode="8004033F" Cause="false"><![CDATA[A database error occurred while executing Stored Procedure "EDA_PUBLICATIONS.FINDBPCONFLICTS".]]><tcm:Token>EDA_PUBLICATIONS.FINDBPCONFLICTS</tcm:Token></tcm:Line>
<tcm:Details>
<tcm:CallStack>
<tcm:Location>Oracle.DataAccess.Client.OracleException.HandleErrorHelper(Int32,OracleConnection,IntPtr,OpoSqlValCtx*,Object,String,Boolean)</tcm:Location>
<tcm:Location>Oracle.DataAccess.Client.OracleException.HandleError(Int32,OracleConnection,String,IntPtr,OpoSqlValCtx*,Object,Boolean)</tcm:Location>
<tcm:Location>Oracle.DataAccess.Client.OracleCommand.ExecuteReader(Boolean,Boolean,CommandBehavior)</tcm:Location>
<tcm:Location>Oracle.DataAccess.Client.OracleCommand.ExecuteDbDataReader(CommandBehavior)</tcm:Location>
<tcm:Location>System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader(CommandBehavior)</tcm:Location>
<tcm:Location>Tridion.ContentManager.Data.AdoNet.DatabaseUtilities.ExecuteReader(StoredProcedureInvocation,CommandBehavior)</tcm:Location>
<tcm:Location>Tridion.ContentManager.Data.AdoNet.Oracle.OracleDatabaseUtilities.ExecuteReader(StoredProcedureInvocation,CommandBehavior)</tcm:Location>
<tcm:Location>Tridion.ContentManager.Data.AdoNet.Oracle.OracleDatabaseUtilities.ExecuteReader(StoredProcedureInvocation,CommandBehavior)</tcm:Location>
<tcm:Location>Tridion.ContentManager.Data.AdoNet.DatabaseUtilities.ExecuteReader(StoredProcedureInvocation)</tcm:Location>
<tcm:Location>Tridion.ContentManager.Data.AdoNet.Oracle.OracleDatabaseUtilities.ExecuteReader(StoredProcedureInvocation)</tcm:Location>
<tcm:Location>Tridion.ContentManager.Data.AdoNet.ContentManagement.RepositoryDataMapper.Tridion.ContentManager.Data.ContentManagement.IRepositoryDataMapper.FindBlueprintConflicts(TcmUri,IEnumerable`1)</tcm:Location>
<tcm:Location>Tridion.ContentManager.ContentManagement.Repository.AssertBlueprintConflicts()</tcm:Location>
<tcm:Location>Tridion.ContentManager.ContentManagement.Repository.OnSaved(SaveEventArgs)</tcm:Location>
<tcm:Location>Tridion.ContentManager.CommunicationManagement.Publication.OnSaved(SaveEventArgs)</tcm:Location>
<tcm:Location>Tridion.ContentManager.IdentifiableObject.Save(SaveEventArgs)</tcm:Location>
<tcm:Location>Tridion.ContentManager.IdentifiableObject.Save()</tcm:Location>
<tcm:Location>Tridion.ContentManager.BLFacade.IdentifiableObjectFacade.Update(UserContext,String)</tcm:Location>
<tcm:Location>XMLState.Save</tcm:Location>
<tcm:Location>Publication.Save</tcm:Location><tcm:Location>Request.SaveItem</tcm:Location><tcm:Location>XMLResponder.Request</tcm:Location></tcm:CallStack></tcm:Details></tcm:Error>

The error says that an error occured while executing SP EDA_PUBLICATIONS.FINDBPCONFLICTS which I believe is for checking blueprinting conflicts. We have checked our items and didn't find any localized folder or item which can cause the problem. We have also tried porting from different publication without success. Is this some issue with the database itself or are we missing anything?

  • 1
    Also check the publication itself, specifically tcm:0-28-1 and if you're importing schemas from and to the right level. 28 seems somewhat "low" for schemas (which would typically be in something like "010 Schemas" as one of the first few Publications). – Alvin Reyes Aug 7 '14 at 12:10
  • 1
    And I would definitely expect to see an upper-level API error rather than a Stored Procedure error... Which versions of Tridion are you porting to and from? – Nuno Linhares Aug 7 '14 at 13:40
2

You may notice in the content porter interface that while selecting the item(s) under a Publication, the Publication itself is also automatically selected as one of the items to be content portered. If you don't want the Publication properties to be changed, you may right click on the Publication and select 'Selected Children only'. This will deselect the Publication

Related: Error while porting pages through Content Porter - "The following items are used in a child Publication"

| improve this answer | |
  • Removing dependency on publication is working but still not able to find the root cause. for some of the publications porting is working fine but for other not. Also in another environment its working fine for the same publication. – rdhaundiyal Aug 14 '14 at 5:49
0

I regularly see "transaction canceled by user" error messages from Oracle database in Tridion setups when performing content ports; I choose to ignore them and retry as they appear to be random and (most likely) related to improper Oracle configuration and/or maintenance.

Can you confirm this is a recurring error that happens every time when you try to port the given schema? Does it happen for any schema or is it a specific schema? Does porting content always work?

| improve this answer | |
  • Its a recurring error and we are getting the same error mentioned by you. We are able to port all the content from all publication except top 4 publications from where error has started appearing – rdhaundiyal Aug 21 '14 at 11:47
  • Is your blueprint very large and deep and only the top layers give this error? I'm thinking you might be hitting a timeout while checking for blueprint conflicts which would obviously be a heavier operation higher up in the blueprint hierarchy... Maybe try porting them to a single publication (not part of your BP hierarchy)? If that does work consider increasing database timeouts in the configuration... – Bjørn van Dommelen Sep 10 '14 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.