5

Which version of MS Visual Studio do I need to develop for SDL Tridion 2013?

4
  • Posted a question I answered for someone else. Maybe it can help others too.
    – Jan H
    Aug 22, 2014 at 10:22
  • 1
    Well phrased question avoiding the daunted support word. :-) Aug 22, 2014 at 18:40
  • Who mentioned support? :) Tridion supports specific .NET versions, that's what the product is tested with. Tridion probably at least partially works with other .NET versions too. This question indirectly is more about Microsoft support, Visual Studio 2005 does not support compiling for newer .NET versions.
    – Jan H
    Aug 23, 2014 at 7:10
  • 1
    Indeed, but people often get confused about this. For the old APIs there were always people that insisted that only Visual Basic was supported, while in fact, compliance with the COM specification was the key issue for support, not the tooling you used.
    – Dominic Cronin
    Aug 24, 2014 at 7:16

3 Answers 3

4

Any IDE that produces .NET assemblies should work. For development for SDL Tridion 2013 SP1, SDL reccomends Visual Studio 2012. Visual Studio 2005 cannot compile .NET assemblys in the correct .NET version.

SDL Tridion 2013 SP1 uses Microsoft .NET Framework 4.5.1 or Microsoft .NET Framework version 4.0.; MS Visual Studio 2005 can only compile .NET 2.0 and with extensions .NET 3.0. To develop for .NET 4.5.1 you will need Visual Studio 2012. For .NET 4.0 you could use Visual Studio 2010.

4

It depends on how awkward a development process you are happy with. In principle, you can write your code in any .NET language, using the editor of your choice. Emacs, Vi, Notepad++++... whatever.

The thing is... you don't need an IDE at all. You could simply obtain the relevant .NET SDK from Microsoft's download page, install it, and use the compilers to build your assemblies.

Generally - you'd want IDE support while writing code, but it isn't necessary, and the SDK-only option might be appropriate for, say, a build server.

2

SDL Tridion 2013 SP1 still supports (Deprecated) the .NET Framework 3.5 SP1. Visual Studio 2005 only supports the .NET Frameworks 2.0 and 3.0. Having said that you can still compile a DLL using the .NET Framework 2.0 and use it. However, I do see an issue if you want to reference Tridion DLLs that are compiled using the .NET Framework 3.5 and higher.

1
  • Typically if your are developing for SDL Tridion you want to reference to the Tridion DLLs so that will be in issue indeed ;)
    – Jan H
    Aug 23, 2014 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.