5

I need to implement ASP master page along with XPM inline editing.

Earlier I added "Enable inline editing for Page" TBB in Master page template and all pages refer to this master page.

But in that case, whenever I edit any page XPM breadcrumb shows that Master page is getting edited. If I add/delete any component, it gets added to Master page instead of the page which was edited.

enter image description here

It is obvious that this is due to the XPM tag (<!-- PageSettings -->) that is present in the Master page - which contains Master Page's TCM ID.

I believe that each page should have their own PageSettings Tag, but if I put inline editing TBB in individual pages, the PageSettings tag comes after which throws error. (not accepted by ASP)

Master.master

<html>
<head><head>
<body>
<!-- header html -->
<asp:ContentPlaceHolder ID="contentPlaceholder" runat="server">
</asp:ContentPlaceHolder>
<!-- footer html -->
</body>
</head>

I have an Aspx page, "page1.aspx" using this master page:

<%@ Page Title="" Language="C#" MasterPageFile="~/Master.Master" AutoEventWireup="true" %>
<asp:Content ID="Content1" ContentPlaceHolderID="contentPlaceholder" runat="server">
<div>This page is using master page, it will have ComponentPresentations along with 
required Inline editing tags for component's fields.</div>
</asp:Content>

I had a look at the following question: https://stackoverflow.com/questions/10604720/sdl-tridion-ui-using-net-master-pages

But not able to resolve the "<!-- SITE_EDIT_INIT -->", this does not get resolved after publishing. Is there anything that I am missing here.

How can I put the PageSettings tag at a particular position in the page. Then, I will have a separate placeholder in ASP master page for this PageSettings, which can further be filled up by the page which will be using this master page.

Please suggest the solution.

Thanks.

  • Thanks Rob for the quick solution. I have tried the same but after publishing SITE_EDIT_INIT is not getting replaced by the PageSettings tag. I added "Enable inline editing on Page" tbb to the page. Is there anything missing. Version: 2013sp1. – Saurabh Mehndiratta Sep 4 '14 at 16:04
  • 2
    Please note that the you should use <!--SITE_EDIT_INIT--> without spaces, the documentation doesn't mention it correctly (there is a comment about that in the 2013 SP1 docs) – Bart Koopman Sep 4 '14 at 16:27
5

If I understand you correctly, the way we have solved this is by using:

<asp:ContentPlaceHolder runat="server" ID="SiteEditSettings">
</asp:ContentPlaceHolder>

in the Master Page and position accordingly.

Then in Page Template designs:

<asp:Content ContentPlaceHolderID="SiteEditSettings" runat="server">
        <!--SITE_EDIT_INIT-->
</asp:Content>
  • Thanks a lot both of you (Rob and Bart)... this has resolved the issue. There should be no space around SITE_EDIT_INIT... <!--SITE_EDIT_INIT-->... thanks again.. :) :) – Saurabh Mehndiratta Sep 4 '14 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.