2

Since upgrading from Tridion 2011 to 2013 SP1, we can no longer send inherited content (components or categories/keywords) to TMS.

We have the following Blueprint structure set up;

  • 00 Root (standard)
  • 01 Master Assets (Schema's and Categories / Keywords)
  • 02 Master (Language) Content (Master component content, a publication for each language English, French, German etc, with a source configuration in TMS for each language to English pairing - no configuration for English to English)
  • 03 Translated Master English Content (Publication layer for TMS configuration English content to all Languages)
  • 07 Specific (language) content (target publication for all source and translated content

I can send content to TMS from each publication (with a TMS configuration) if the content is local to that publication. If the content is inherited from a parent publication the option to translate is not available or blank transactions will be sent through to TMS.

I have been able to prove this by adding the 03 TMS configuration (English to all languages), to 02 Master English content. This allows me to send 02 local content from 03 publication (inherited). However, if I try to send a category inherited from 01 Master Assets at 03 publication, the translation transaction is blank.

This blueprint and TMS configuration worked in 2011 and I really don't want to be adding the TMS configuration at every parent level.

Any help or advice would be greatly appreciated.

2

SDL have released a hotfix to bring back this business rule which was present in Translation Manager 2.0.

Hotfix TT88066 is included in the cumulative hotfix CM_2013.1.0.88313.

We will be implementing this over the next couple of days.

1

There is no intentional change in this area as far as I remember. So you should probably contact support and try to find out if it's a defect in Translation Manager or something in your setup that is causing this.

  • Hi Lars, Thanks for your reply. I was told by support there was a change in business logic since Translation Manager 2.0. The hotfix above brings back the business rule to allow this and worked on their build, however we still have an underlying issue we are working with SDL to resolve. I will provide further feedback when we get to the bottom of it. – Steve Redgewell Dec 17 '14 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.