7

Within an upgraded environment from 2009 to 2013sp1, there are components that have an approval status "Live", the schema, that these components are based on was associated with a workflow process in the past. the workflow association has been removed from the schema (not recently)

After saving the component in 2013sp1 environment, the approval status of the components is set to "Unapproved" by the system. this isn't the case in a 2009 env.

In the CM db there is no references in the workflow related tables, in the ITEMS table is the only reference to the approval status.

Is the "Unapproved" status set by the system a default value? and is it configurable?

Update

Hotfix available on tridionworld: CM_2013.1.0.88203

3

I have experienced this same behaviour in 2013 and 2013SP1. It can occur when components have previously been run through a workflow (i.e. have some approval status) and are subsequently edited when the workflow association no longer exists (this can happen if the association has been removed completely or if you are working at a lower level in the BluePrint and both the component and the schema have been localised with the association removed).

I worked around it in 2013SP1 by creating a simple workflow with a single automated activity that approves components, then using an Event System that fires on Component check-in to check for the condition and then create and start a workflow process (using that workflow) with the problematic components.

This workaround is in the process of being removed as I am currently testing a hotfix (for 2013SP1) that changes component's status to 'Undefined' instead of 'Unapproved' in these circumstances, thus making them publishable.

See Gist for code details

  • Thanks David, Is there a hotfix available? – Siawash Shibani Oct 2 '14 at 11:36
  • I'm testing something. I'm not sure if it's generally available yet. Suggest you talk to Customer Support? – David Forster Oct 2 '14 at 11:38
  • awesome. I will contact CS. – Siawash Shibani Oct 2 '14 at 11:39
  • The Hotfix CM_2013.1.0.88313 worked for us. – Trevor Bartlett Dec 5 '14 at 21:37
0

So the situation is the next.

  1. You had workflow process, which has been finished (and new process has not been started on your component).
  2. Component still has some approval status (despite it is not in the Workflow).

Yes, 2013 SP1 has next behavior - on saving such component (or another WorkflowItem) Approval Status is invalidated to Unapproved value. It is not configurable in 2013 SP1. In next release behavior will also be changed... and at least you will be able to set another default value for resetting approval status by event system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.