2

I have 2 groups of components in 2 folders, both are not linked to any page, they are just standalone components, components in folder A are available in broker database and components in folder B are not in Broker db. I could not find any difference of components of folder A and folder B. I right click and publish the component, If i check what get published I see no items, each component has "Tile" and "Summary" as shown in image blow, I expect this metadata information should be stored in "Custom_Meta" table of broker database,

How can i store this information in database?

enter image description here

my storage file has following lines

<Storage Type="persistence" Id="Sql" dialect="MSSQL" defaultStorage="true" Class="com.tridion.storage.persistence.JPADAOFactory">
            <Pool Type="jdbc" Size="10" MonitorInterval="60" IdleTimeout="120" CheckoutTimeout="120" />
            <DataSource Class="com.microsoft.sqlserver.jdbc.SQLServerDataSource">
                <Property Name="serverName" Value="xyz" />
                <Property Name="portNumber" Value="xyz" />
                <Property Name="databaseName" Value="tridion_broker" />
                <Property Name="user" Value="xyz" />
                <Property Name="password" Value="xyz" />
            </DataSource>
        </Storage>
        <Storage Type="filesystem" Class="com.tridion.storage.filesystem.FSDAOFactory" Id="File" defaultFilesystem="false">
            <Root Path="C:\inetpub\my application" />
        </Storage>

<ItemTypes defaultStorageId="Sql" cached="false"> <Item typeMapping="Page" cached="false" storageId="File"/> <Item typeMapping="Binary" cached="false" storageId="File"/>

Only pages and binary would be stored on file system and all other things should go to database.

Update just found components in folder A are linked to a component template but components in folder B are not linked to any component template. trying to create a component template for components in folder B. I am able to link components to a template and that template is used by a page but when I publish a page I see success in logs but logs does not display any component being published.

  • How do you publish this component? Rightclick -> Publish on the component itself or do you publish the page? If you publish the component itself, it has to be linked to a dynamic CT. (Check what gets published by clicking on the 'Show items to publish' button in the Publish dialog). – Albert Romkes Oct 24 '14 at 9:55
  • Are there any errors in the cd_deployer log? If you set logging to DEBUG, you'll see exactly what happens. :) – Raimond Oct 24 '14 at 11:34
  • Question updated for more information. – Ali Oct 27 '14 at 0:25
3

You need to properly configure the cd_storage_conf.xml configuration file of the deployer web application (assuming you use the web application deployer and not the windows service).

This file is normally located in the bin/config folder of your web application. Could you post the contents of this file (leave out the comments and change the username/password/servername of the database nodes obviously)?

To store items in the database the default storage id of your itemtypes node should be set to point to the database store:

<ItemTypes defaultStorageId="defaultdb" cached="false">

here is a link to the Tridion 2013SP1 content delivery deployer setup documentation from SDL (login required!).

  • <ItemTypes defaultStorageId="Sql" cached="false"> <Item typeMapping="Page" cached="false" storageId="File"/> <Item typeMapping="Binary" cached="false" storageId="File"/> – Ali Oct 24 '14 at 7:56
  • I have another folder with component and same metadata structure and they are available in broker database. – Ali Oct 24 '14 at 7:57
  • fixed and raised another question tridion.stackexchange.com/questions/8231/… – Ali Oct 27 '14 at 3:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.