1

Bulk publishing is not working on environment and get the below issue.

“The number of render failure has exceeded its specified failure limit of 0”

“Could not load file or assembly 'Tridion.Extensions.ContextExpressions.Common, Version=7.1.0.23, Culture=neutral, PublicKeyToken=ddfc895746e5ee6b' or one of its dependencies. The system cannot find the file specified.”

Whereas if we are trying to publish single page then publishing is happened. eventhough bullk publishing is properly working on other environment.

I even checked the above dll and that presents into the GAC.

  • Do you have multiple publishers? Are you in a load balanced environment? Are you sure there's no other system connected to the same database? – Andrey Marchuk Oct 28 '14 at 12:15
  • 1
    Have you tried restarting the 'Batch Processor' service? Also make sure that the user the service is running as (e.g. NetworkService) can load the DLL. If it's not a file system permissions issue, I suggest using Fusion Log Viewer to see what the exact problem is. – Peter Kjaer Oct 28 '14 at 12:24
  • @user978511 : Having only one publisher, no load balancer, database server is common for preview/XPM and live environment but databases are diffrent. – Nash Oct 28 '14 at 12:43
  • @Peter: yes I did, even I restarted server. Batch processor service is running as Networkservice user. – Nash Oct 28 '14 at 12:47
  • 1
    Do the items end up in the publishing queue? Does it happen when you publish multiple items or when you publish an organizational item or template? – Chris Summers Oct 28 '14 at 17:04
4

I'm not sure whether this occurring only for 'batch publishing' is a red herring.

I was getting the same error after doing a database refresh from Production back to a Development environment. It appears that the 'Context Expressions' functionality had been installed on Production, but not on Development. (Either that, or it was not installed 'fully'.)

enter image description here

After re-running the installer, with the Context Expressions option checked, publishing worked fine again.

It may also be worth noting that if you have an outscaled Publisher (with the Publisher on a different server than you main Content Manager install), then you'll have to re-run the installer with the Context Expressions option checked there too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.