4

I am getting the issue Polling for notification for destination: has exceeded polling attempts for transaction

What is the max setting I can use in the httpupload web.config?

  • maxRequestLength
  • maxAllowedContentLength

Also, in the cd_deployer_conf, what is the suggested timeout for polling? Is there a max?

6

The maximums are different units, strangely - one is kilobytes, and the other is bytes!

 <?xml version="1.0"?>
   <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">         
        <system.web>
            <!-- This value is in **kilobytes** -->
            <!-- http://stackoverflow.com/questions/4548305/maximum-value-of-maxrequestlength (See the answer by Petr - not the accepted answer) -->
<!-- 2097151 kilobytes = 2.09715 GB --><httpRuntime executionTimeout="1200" maxRequestLength="2097151" useFullyQualifiedRedirectUrl="false" minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100"/>
        </system.web>

        <system.webServer>
            <security>
            <requestFiltering>
                <!-- This is the value in **bytes** -->
                <!-- 524288000 bytes = 500MB -->
                <!-- The maximum for this is 4,294,967,295 (3.99GB) - http://stackoverflow.com/questions/4022434/-->
                <requestLimits maxAllowedContentLength="524288000" />
            </requestFiltering>
            </security>
        </system.webServer>    
    </configuration>

I'm not sure about the maximum timeout for the polling. However, in addition to the web.config settings above, you may also need to add a MaxSize attribute to the HTTPSReceiver element in your cd_deployer_conf.xml configuration file:

< HTTPSReceiver MaxSize="2147483648" Location="C:\Program Files\Tridion\incoming" InProcessDeploy="true"/ >

(Reference: http://tridion.kb.sdl.com/#tab:homeTab:crumb:7:artId:4065)

| improve this answer | |
  • After 20 minutes of "Committing Deployment" it fails with the error message in the question. The page contains several MBs of images and is a very 'heavy' page. Any other ideas? – robrtc Oct 30 '14 at 13:28
  • Are the items that you are publishing arriving in the 'Incoming' folder at all (as a zip file)? If not, is there anything in the webserver logs? If so, then could it be a problem with the Deployment process itself (rather than the uploading of the publishing package)? – Jonathan Williams Oct 30 '14 at 13:44
  • While it was in the Committing Deployment phase, it was nowhere to be found in 'incoming'. However, all other pages are publishing fine. Not sure what is happening under the water in the last stage. – robrtc Oct 30 '14 at 13:53
  • It could be worth checking your transport service logs (I think that these can be seen in the Windows Event Viewer) for anything. You could also set cleanup="false" on your Deployer, to see whether the Publishing Package is ever arriving in the Incoming folder at all. – Jonathan Williams Oct 30 '14 at 14:50
1

To the first question you asked, below is my understanding:

The maxRequestLength specifies the maximum file upload size supported by the application/service, whereas the maxAllowedContentLength specifies the maximum length of the content in a request supported by IIS Web Server.

To deal with large transport package size, we need to set both maxRequestLength and maxAllowedContentLength in the web.config - if the values are different, the attribute having smaller value takes the priority

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.