8

Unable to delete schema in SDL Tridion 2011 SP1 There is no reference to the schema, yet unable to delete it. Even Using Where used didn't find any references to this schema.

Any Fix available for this or is it known bug?

I have tried removing it from the owing publication, but still not able to. I see two different publication one is original and other is shared. but no references are there.

It shows an pop "This item is in use" but when you click on where used it has only old version references which "only used in old version"

9

You need to remove that old version that is referring to your Schema. Make a note of the specific version(s) that were using it in the "Where Used" dialog.

Then if you open up the version history of the item that was using your Schema (ensure you do this at the item's owning Publication), you can now delete the version by right clicking on it.

enter image description here

The reason that you cannot delete the Schema is because if you rollback the item that was using the schema (a link still exists in the database) to the version where it was using that Schema, the Schema would need to exist.

  • Might be good to explain the reasoning behind this. A Schema defines the XML structure, so this remains a valid link also for older versions. Because if you would rollback an item to a older version, that will still require that Schema, hence the difficulty you have when trying to delete it. – Bart Koopman Apr 10 '13 at 7:54
  • Thanks Rob Stevenson-Leggett, it got deleted, but here a CT had a schema linked and when i removed the CT reference in the history it was delete. Thanks for your suggestion it helped. – vishal jetha Apr 10 '13 at 8:16
  • Vishal, if the issue you were facing is resolved then please mark this post by Rob as the answer to the question. – Kunal Apr 10 '13 at 8:27
  • @BartKoopman updated to include some explanation – Rob Stevenson-Leggett Apr 10 '13 at 8:30
8

Vishal,

Did you try doing a "Where Used" on the owning publication level?

The error that you get "Only used in old version" indicates that the schema is still in use by some items in older versions.

You might need to manually go to the item history and delete any older versions of item that have reference to the Schema before you can remove the Schema from the system.

Regards, Kunal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.