10

This is a brand new installation of Tridion 2013 SP1 on WS12 with SQL 2012. The interface loads with no issue. I can add user favorites and create publication targets and target types. However, when I try to create the 1st publication i get the following error:

(80040356) Unable to save new item The transaction has aborted.

This error is coming straight from the interface. I am not using a CoreService client.

I have verified and performed the following steps:

  • Ran the following query for binary updates: SELECT 1 FROM BINARIES WHERE ID = -1 AND CONTENT IS NULL
  • Uped all DB timeout values by x10 (300, 6000, 500)
  • Verified DTC settings
  • Added network service and MTSUser read and execute to Tridion installation directory
  • Added MTSUser as impersonation user
  • Restarted multiple times
  • Updated SQL Stats: exec sp_updatestats
  • Changed temp folder to be within Tridion/Temp
  • Changed autogrowth and log size for DB per install instructions
  • Changed all services to run under the MTSUser

Nada. Still getting the same error. Anyone have any ideas?

Thanks in advance.

UPDATE The SQL version was Express and not full SQL Server 2012. Having full SQL installed and will re-install Tridion after that. Will post back with results.

  • 1
    I know you mentioned you verified DTC settings, but could this be a DTC issue? I know that DTC is now only used for a few things so you may see Tridion operating as normal until it tries to do something with a distributed transaction – Will Price Dec 4 '14 at 12:33
  • 1
    Is there more stacktrace in the event viewer log? – Nickoli Roussakov Dec 4 '14 at 12:51
  • @NickoliRoussakov: Not much else in the stack from the log. My BP is removing SQL Express for the full version, if the issue still persists i will post the full error. – Trevor Bartlett Dec 5 '14 at 4:02
  • @WillPrice: Once they bring the server back up after the full SQL install i will test DTC for any issues, might be firewall as well...more to come. – Trevor Bartlett Dec 5 '14 at 4:03
6

This can be solved by correctly configuring MS DTC. As a base guide, follow this guide by Chris Morgan: Installing Tridion & beating MS DTC

Note that you will have to do this on both the SQL server machine as well as the CM and other machines which also connect to the Tridion CM database, like a separate Publisher.

In addition to the blog post, I found that a couple of more things need configuring on all machines:

  • Opening up the Firewall. Ensure all ports can be reached. Windows Server 2012 has some predefined rules which you can easily turn on. This goes for all machines communicating with each other
  • Ensure that the user running MS DTC (Usually NETWORK SERVICE) has sufficient local and remote, default and launch permissions. Again, this goes for all machines communicating with each other.

Next, you can check with Dtcping whether the servers can reach each other.

Finally, something I've found recently in WS 2012: if you have installed SQL Server before enabling MS DTC and if you need to confgure MS DTC afterwards, the whole server needs a reboot in order for new settings to propagate!

1

Unfortunately the issue went away with the install of the full version of MSQL. Thank you for all your ideas.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.