Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [dxa-2.0]

The tag has no usage guidance.

2
votes
3answers
45 views

Web 8.5 - ECL - Get metadata

We have a requirement to use both external metadata and internal metadata of ECL items. We were able to define both in the schema and are able to use and get the external metadata as well. But the ...
1
vote
1answer
49 views

Configuring microsite functionality using ContextUrls or RelativeUrls

I'm seeing a localization error when testing microsite functionality in Web 8.5 and DXA 2.0 (.NET), ie servername:port/abc. I see there are two ways to do this, using either the server-relative URLs ...
4
votes
1answer
44 views

DXA: KeywordModelData missing from Dynamic Component using GetEntityModelData in .Net

While trying to retrieve Content using dynamic component presentation, the KeywordModelData returns only the ID and other values are missing. For the field "name" as shown below. The same question ...
4
votes
3answers
174 views

Tridion Sites 9 and DXA 2.0

Does anybody knows what happens with Tridion Sites 9 and DXA 2.0? I think I have all the configuration files and settings ok, but I am not able to make it work. Is there any known issues? Any ...
1
vote
0answers
33 views

Running web application locally in Eclipse returns HTTP status code 500

The situation is that I'm running a local DXA webapp in Eclipse that should communicate with the CD server so I can test a website. The problem is that I can't get past the HTTP status code of 500 (...
0
votes
0answers
19 views

DXA 2.0 - Updated build-files.zip not getting reflected

Since the DXA default "build-files.zip" was not meeting our requirements, we decided to modify the gruntjs file in a way that we are able to create assets as per our requirements. We were able to do ...
0
votes
1answer
23 views

How to add scoped repository values in topology manager

I have multiple websites under a topology manager. For some of the websites i have scoped repository values and for some i dont have the values. How should i add the scoped respository values for the ...
1
vote
1answer
48 views

DXA 2.0 - No semantic mapping between schema error

We are creating all new schemas/views/models as per our project's requirements. One of our schemas is a bit complex because of the vast requirements that we have. Here is a basic structure: Schema 1 :...
6
votes
1answer
26 views

Timezone difference causing stale configuration and content in DXA 2.0

Our DXA 2.0 web app servers use Central European Time (CET) and access microservices hosted by SDL on servers using UTC/GMT. We have noticed that content and configuration was not always updated in ...
3
votes
1answer
43 views

Unable to call OData service for “http://abc-xyz.com:8082/discovery.svc” URL and service query “/TokenServiceCapabilities”

In our DXA application, we are trying to check connectivity of our webapp to a new PROD CMS Environment. However, I keep getting the following error, trying to run the app, and not sure why it cannot ...
1
vote
1answer
44 views

DXA 2.0 - Add Content data field as Sort Parameter in Broker query

Currently the code available in Core module help us to include sorting parameter for brokery query as shown below. This implementation has option to include Meta key for Metadata field. But i need to ...
3
votes
1answer
48 views

DXA 2.0 - Get ComponentTemplateId using Component Id in .Net

To render dynamic contents, using broker query to get related components tcmuri. Now using these component tcm-uri's need to get the Component Template Id. Since we need both Component Id and ...
1
vote
1answer
31 views

DXA 2.0 import failed

We are facing one issue while importing DXA 2.0 . We did following steps to import DXA: Copied the DXA Application Data Definition.xml file to %TRIDION_HOME%\config\ImportExport\ApplicationData\ Run ...
1
vote
2answers
90 views

The expandLinkDepth is not working Tridion DXA 2.0

I am duplicating this [question] (How to set nested component linking level in DXA). My issue is with "R2 Render Content" Component Template in Web 8.5 and DXA 2.0 A developer created a component ...
0
votes
1answer
56 views

How to resolve component links in Rich Text Field when getting content from BrokerQuery?

By default DXA resolves Component Links in Rich Text field and Component Link fields when rendering the components directly. But when we get the contents as a result of our broker Query and then ...
1
vote
1answer
59 views

Custom PageModel not loading SG metadata DXA 2.0

We have created a custom page model in order to get the metas of the SG in our page. The PageModelData contains the values in the field metadata. But when mapping to our customPageModel class, we don'...
1
vote
0answers
27 views

How to use DXA ContentProvider class to Obtain PageModel and Entities in a SpringBoot application

We have implemented an API that we are going to use in our mobile applications, what we are trying to do is to re-use our Entities classes that we created for our Web applications, but when we are ...
0
votes
0answers
40 views

Not getting proper localization component

we are having 2 languages in our website (English and Arabic) with DXA 2.0. but with this code, we are getting arabic localization component and arabic value in the variable "pageTitlePostfix". @...
5
votes
0answers
30 views

No way to leverage Tridion proximity logic in link resolving with DXA 2.0?

Tridion Dynamic Linking has built in proximity logic, that means that if the same component is on two pages, dynamic linking will link to the page which is 'nearest' the source page containing the ...
2
votes
1answer
45 views

DXA static content folder

I am trying to use some static css files from file system path like ~/design/css/imagename. In trace log it seems dxa is searching these files in broker. Can anyone suggest if we need to configure ...
2
votes
1answer
19 views

Issue with passed entityClass to SemanticMapper.createInstance() is null

We are trying to build a Java service that fetches json data through DXA. We only need the raw data from a REST service. We created a class that extends AbstractEntityModel but it seems like the class ...
4
votes
2answers
55 views

DXA 2.0 GetNavigationModel url Property for Keyword is null

I am working with a client that has DXA 2.0 (.NET) and SDL Web 8.1. DXA Unity.config is configured to use the DynamicNavigationProvider The Sitemap [Navigation] Category has been published Pages ...
2
votes
1answer
47 views

DXA content images have CID markup prepended, even though CID was not used for image transformation

For a new server with Web 8.1.1 and DXA 2.0 (.NET) and no modifications, on browsing webpages admins see that all content images have markup such as the below and hence images are not displaying ...
1
vote
0answers
45 views

DXA 2.0 issues getting static content

In SDL 8.5 we uploaded an mp4 file with size 17 MB. The size of the file in the target folder of the DXA 2.0 Java application is only 5 MB. The DXA-application shows the stack-trace beneath this post ...
4
votes
1answer
58 views

Disable Experience Manager (XPM) DXA 2.0 Java, for specific CT

I have an issue with the DXA Experience Manager. We have XPM in some Component Template of out site, but we need to disable it for specific ones. So we have unchecked the "enable inline editing" in ...
0
votes
0answers
22 views

Default encoding gets reset to ISO-8859-1 encoding after after few requests from restart

Recently we have noticed that our form submitted Arabic fields are encoded with ISO-8859-1. We have set character encoding on all files, tomcat connector, in the entity controller but after this ...
2
votes
1answer
83 views

Taxonomy navigation in DXA 2.0 throws exception

I am implementing a taxonmy based navigation in SDL Web 8.5 with DXA 2.0. According to the documentation, I have created a category keyword with [Navigation] in its title. I have published this ...
0
votes
1answer
29 views

DXA Resolver Recursion Depth

We have set in the CMS, in Administration > DXA Resolver Recursion Depth the following value DXA Resolver Recursion Depth=2 but we are getting infinite loop when accessing the service model. Does ...
3
votes
1answer
100 views

Extended KeywordModel with metadata fails when metadata empty

This is the metadata schema that we have linked to a keyword @Data @SemanticEntity(entityName = "HotelMeta", vocabulary = SDL_CORE) public class HotelKeyword extends KeywordModel { @...
0
votes
2answers
45 views

SDL Web 8.5 DXA sample app 404

I am seeing below error in model service log. And 404 received on the website for all pages. Let me know what I am missing in configuration. 2018-07-12 04:19:46,118 WARN c.s.d.m.s.p.e....
2
votes
2answers
51 views

DXA R2 ModelService returning 404 Not Found for Child Publication Mappings

UPDATE: Topology Mappings screen grab (host name obscured) We have setup a new instance of SDL Web 8.5 with DXA v2.0 and the Model Service using the R2 data model. Working Example (not accessible ...
1
vote
1answer
72 views

Not able to get schema name for Linked Component in DXA2.0

Below is DD4T code that I need to rewrite to DXA. Find the Schema name of the Linked Component and perform an action based on the schema. IComponent component = Model.Fields["linkedComponent"]....
2
votes
2answers
96 views

DXA 2.0 resolves Component Links in Rich Text Field without Page extension(.html)

Upgrading from DD4T to DXA. our website by default will have extensions ex(http://www.mysite.com/index.html) but By default DXA resolves Component Links in Rich Text field and Component Link fields ...
0
votes
0answers
56 views

High memory utilization with DXA 2.0

We are using SDL Web 8.5 and DXA 2.0 Java. DXA Web application is deployed on high configuration Linux server (16 GB Ram and 8 core CPU) using Tomcat 8.5.30. We are experiencing high memory ...
0
votes
0answers
40 views

Error while running load test on DXA 2.0 website using JMETER with HTTP/2

We are using SDL Web8.5 and DXA 2.0 Java Web application while doing load test using JMeter 4.0 with HTTP/2 protocol enabled we are getting below error.The same with HTTP/1 working fine org.apache....
4
votes
2answers
137 views

What does it mean “Non Public Model Service” in DXA?

My question may not make much sense to many but want to clarify my doubts. I read DXA doc which says OOB we will have non-public restful web services: 1) Does this mean that these services are not ...
5
votes
2answers
75 views

Install DXA 2.0 Resolver on the Publisher machine?

We have a separate Publisher and CMS machine. While installing DXA 2.0, we are installing the Resolver using the command .\cms-customresolver.ps1. (btw, while running with .\cms-customresolver.ps1 -...
1
vote
0answers
62 views

SDL Web 8.5 Custom Page Deployer - How to access component custom meta

We are upgrading from SDL Tridion 2013 to Web 8.5 and have had to make several changes to our custom deployer for PageDeploy/Undeploy and ComponentDeploy/Undeploy. At this point we have all 3 of 4 ...
1
vote
0answers
62 views

DXA 2.0 Page Metadata

In DXA 1.7 the Page Model object had a Meta collection of the Metadata fields on the Page. In DXA 2.0 this is empty. How do we access the Page Metadata in DXA 2.0?
2
votes
1answer
108 views

org.springframework.http.converter.HttpMessageNotReadableException: Could not read JSON document: Unexpected character

We are getting the below error message when trying to read content that has href tag and results in bad request. 15:08:57.712 [ajp-nio-9014-exec-1] DEBUG o.s.c.a....
6
votes
1answer
91 views

How to handle component link circular reference in DXA 2.0?

I have Book schema, that has a component link to similar books. One of the similar books, has a component link back to original component. In such way I got circular reference. When publishing this ...
6
votes
1answer
65 views

Embedded Entity not getting the data from the CMS

I am working with a DXA 2.0 Java implementation where I have created 2 custom models, one for a schema and the second one for an embedded schema Below is the code This is for Entity 1 @...
0
votes
0answers
167 views

Missing KeywordModelData from a Dynamic Component using Session Content Model

We use SDL Web 8.5 + DXA 2.O for Java. Is it available somewhere the API for the CIS? We want to retrieve the keywords from a component that it's linked to a dynamic component presentation, but ...
0
votes
1answer
42 views

Navigating images giving 404 error in DXA 2.0

We are using DXA 2.0 with SDL Web8.5.We are publishing images to root structure group of the publication using custom template code but while we are trying to access the image using URL it always ...
2
votes
2answers
56 views

DXA Model service attempting to deserialize static files with no DD4T TBBs

Similar error from previously posted question but we aren't using any DD4T template building blocks in the page/component templates Deserialize DD4T content error while validating DXA Model service ...
2
votes
0answers
33 views

DXA 2.0 Java Too many open files error

We are using DXA 2.0 Java inside RedHat Linux server. The DXA Application is deployed using Tomcat 8.5. While accessing website after some time we are getting 500 error too many open files although ...
1
vote
1answer
82 views

Keyword information not populated

When publishing a Component with a meta field that it's a keyword, the JSON only generates the following information related with the Keyword. This is the JSON generated by the CMS, debugging with ...
2
votes
1answer
92 views

Deserialize DD4T content error while validating DXA Model service

I am following the below url to configure DD4T 2.0 to consume DXA Model Service: http://blog.trivident.com/switching-to-the-dxa-2-model-service-in-your-dd4t-application/ As per above article, when ...
1
vote
1answer
40 views

DXA 2.0 - Query for Pages in Structure Group

In a static publishing solution we have a magazine with a page for a Month / Year and currently at publish time, the index page gets a list of all the other Pages in the same Structure Group. Works ...
4
votes
1answer
59 views

Getting a Null Pointer exception while trying to run a DXA Webapp

I just setup a basic DXA Webapp 2.0.0 trying to get data from microservices hooked up with SDL Web 8.5 and I am trying to run it but I get a Null Pointer Exception. The DXA components were installed ...