Problem is solved. 

I forgot to specify the `includeinworkflow=true` parameter in `ResolveInstructionData`.