Hot answers tagged

14

I have seen problems like this before. Here's the thing: During installation of Oracle client, installer checks for .Net version installed on the box. It then installs corresponding components. In your case, most probably you had .Net 3.5 at that time, so Oracle installer installed components for .Net 3.5. Later, Tridion installer updated your .Net version ...


11

You should upgrade your existing Default Templates by opening Template Builder, choosing Tools | Create Default Building Blocks from the menu, and selecting the parent folder for the "Default Templates" folder in the relevant parent Publication. For instance, if your default templates are in "Building Blocks\Templates\Default Templates", you need to choose "...


9

You have to unblock the Tridion.Database.Management.dll as described in the documentation (bullet 6, login required)


8

Few points need to remember while setting up Tridion on a different machine, which are below You need a different licence file for your new CD server, which you need to put on upload folder. Make sure your all servers allow access by doing changes in your firewall settings. You need to enable a few ports through which you are able to access data. Can ...


7

In Tridion 2013 you do not need YAWF anymore, you can directly write CoreService codes in script window, or even have external compiled activity being executed. In order to understand why it does not, you need to know that since 2013 the TcmWorkflowAgent.exe hands over the execution of legacy scripts to LegacyScriptExecutor which is hosted in Tridion COM+ ...


7

It seems that the upgrade process does not upgrade the Tridion.SiteEdit.Templating TBB - this is needed for the new tags to be interpreted. You need to manually do this, by opening the TBB, and uploading the upgraded Tridion.SiteEdit.Templating.dll (which can be found in [tridioninstallroot]/bin


7

Upgrade should be fairly painless. 2011sp1 and 2013 are the same architecture and so not too many surprises there. If you run VBScript tempalates, you'll need the legacy pack since 2013 no longer requires COM+ for Templates or APIs. You'll need to re-compile any C# TBBs, Core Service, Event System, or other custom applications that rely on Tridion ...


7

For the Java version of DD4T: Tridion 2011 to Tridion 2013 No upgrade needed. DD4T versions 1.31 and 2.0.0+ will work with Tridion 2013 as well, with one important note: The DD4T web application will need to be compiled against JDK 7 and the Tridion CD API version 7.1.0 instead of version 6.1.0. Tridion 2011/2013 to SDL Web 8 In-Process The same is true ...


7

i also faced similar kind of issue which got resolved after applying Hotfix Rollup #1 for SDL Tridion 2013 SP1 as suggested by SDL. Kindly contact SDL for the hotfix or log a ticket in SDL support


7

I believe this is a known defect on 8.1.1 installer, which got fixed in 8.5. The work around involves using a different Topology Manager database for the 2nd install, then change the 2nd server to use the first one (and delete the second one). One has to wonder though... why aren't you deploying 8.5 rather than 8.1.1?


6

The upgrade from Tridion 2011 SP1 to 2013 (SP1 presumably) is fully supported by SDL, well documented and should be quite straightforward. With regards to the upgrade, I would recommend that you do a full audit of the modules and add-on products that you already have, and the APIs that you are currently using, to establish what aspects will need attention ...


6

The issue here appears to be having URL in the Link text. Current implementation of CIL does encode link text but since we have URL, it needs double encoding so that CIS can handle the request. As a workaround, this link text can be encoded before passing it to the API. As a result, the response will contain encoded link text which needs to be decoded again....


6

One workaround I've found is to temporarily move all of the aforementioned templates into temporary new folder locations, to allow the import operation to succeed. Then, once the cms-import.ps1 script is successfully run, the new templates will be in the correct location. Finally, to make this work, it's necessary to compare each of the new templates to the ...


5

It depends on what you want to test with your POC. If your goal is functionality or you also want to perform load and performance tests. I would say give your DB the most resources (especially RAM) as possible, since the Publisher and the CM will slow down based on lack of DB resources. Next, I would give resources to the CM box, because the Publisher ...


5

You shouldn't have Hybrid setups. It is a bad practice to upgrade your environment only partially. Even if as Nuno states you might not find any issue (Tridion typically supports mixed versions of Delivery as a way to help upgrading, it's really not meant to work long term) it is also possible that you might find some. What I would recommend is to upgrade ...


5

It should work if you have a regular Tridion install. However I do see issues in you have installed products like Experience Manager, UGC or any product that is dependent on the Content Delivery Web Service to Push Data or Fast Track Publish. These products need direct connectivity between the CM side and the CD side via a POST method. In case you have ...


5

Actually, you can run a 2011 content manager on a 2013 content delivery. Documentation can be found here: http://sdllivecontent.sdl.com/LiveContent/web/pub.xql?action=home&pub=SDL_Tridion_2013&lang=en-US#addHistory=true&filename=StagedUpgradeSteps.xml&docid=concept_2F44AFBC950B4A5FA354DCF035B2524F&inner_id=&tid=&query=&scope=&...


5

You can Content Port from earlier versions of Tridion in to SDL Tridion 2013 SP1 - I did this recently, between Tridion 2011 SP1 HR1 and Tridion 2013 SP1. One thing to note is that you will need the Content Porter 2013 SP1 Client to be able to import in to SDL Tridion 2013 SP1. Although SDL Tridion 2013 SP1 now comes with the Import/Export Webservice as ...


5

If memory serves me correctly, LDAP has a limit set for the maximum resultset available to a single query. You could ask your LDAP administrator to increase the maxpagesize on your LDAP server (1000 by default). However, this does not explain why it worked in 2011. Alternatively, you could install the AddUser power tool available to download as part of ...


5

It would be totaly same on cloud environment, only thing where you need to put your effort is domain controller for setting up the LDAP otherwise rest is same. and yes need to open few ports between CMS , DB and CD servers. Usually your architecture vary only for the DTAP environments not wheather you are using cloud or your local servers. Dev Environment -...


5

Thanks to Elena Linhares for putting me on the right track. I queried the TDS_DB_INFO table in the Tridion_Broker database and discovered that it had not been upgraded yet as it was showing version 6.1.xxx Upgrading the Tridion_Broker database in the normal way fixed the exception.


5

There are no physical files for schema definitions, not sure where or why you're getting this information. All data definitions are stored in the database, upgrading it using the scripts will provide you the same schemas and templates that you had before. The only things that may need file system copying and re-registering are extensions - UI or event ...


5

With Web 8.5 the Content Delivery framework is via microservices. So it really doesn’t matter what versions of Spring or Hibernate the app is using, unless you’re trying to use the legacy “in-process” configuration approach. If you upgrade to using microservices, then the Spring and Hibernate dependency is on the service itself, which is separate from your ...


5

I think the problem lies in the fact that your event handler is asynchronous (and you're subscribing to the TransactionCommitted phase). A Save action normally happens on the dynamic version (v0) of an item. So, the -v0 in the TCM URI is no surprise. However, if you do a typical save-and-close/checkin transaction, the check-in action typically results in ...


5

It seems you're asking two questions. Do we need to apply the cumulative update Yes. It clearly states (on the link provide by Atila) that you can upgrade from SDL Web 8 "with Cumulative Update 1 applied". I'd suggest it probably makes sense to apply the cumulative update anyway - it's likely you're simply working around a few problems (or even unaware ...


5

You can use DD4T 2.1 in combination with Tridion Sites 9.1. You just need to upgrade the POM so that it uses the 9.1 CIL and related third-party libraries. On the CM side you can use the DD4T 2.5 templates, they will work fine with DD4T 2.1 on the CD side. As you say, you won't be able to use the new functionality, especially regions. But the 2.5 templates ...


4

The absolute best way to migrate Components is to upgrade your database and use that upgraded instance. You can delete Template and Pages you don't need and restructure your Blueprint if required (provided you had a basic diamond model to start off with). Which most of the time is just as much work as trying to figure out what you want to export/import. If ...


4

Your TBBs that rely on the TOM.NET API should be fine. There are a few deprecated methods mostly around Filters, but they are only deprecated and should still work in Tridion 2013. Your Custom DWT Function Sources should also be fine as they rely on TOM.NET. Anything that relies on TOM/TDSE, including Workflow and Custom Pages will require a Legacy Pack ...


4

Couple of things, I suspect for generating 'Import-Module : Could not load file or assembly' error Make sure you enable .Net 4.0 for powershell Create a file “powershell.exe.config” in C:\Windows\System32\WindowsPowerShell\v1.0 <?xml version="1.0"?> <configuration> <startup useLegacyV2RuntimeActivationPolicy="true"> <...


4

I had the same issue, it didn't work because you need to start a field marker before you start a field value marker. Here a sample @@FieldStartMarker("FieldName")@@ @@FieldValueStartMaker("FieldName")@@ @@GetFieldValue("FieldName")@@ @@FieldValueEndMarker()@@ @@FieldEndMarker()@@ I was following a sample with this content. // Wrong @@...


Only top voted, non community-wiki answers of a minimum length are eligible