Peter van der Lugt
  • Member for 6 years, 11 months
  • Last seen more than a month ago
DD4T webapp using discovery service gets 'invalid_grant'
Accepted answer
7 votes

Using Fiddler I found out that the TokenService was registered on the localhost domain. That's why the webapplication (which was running on my local machine) couldn't access the TokenService on the ...

View answer
Best way to store application properties in Storage Extension
Accepted answer
4 votes

Found my answer on: http://www.tridiondeveloper.com/using-a-configuration-file-for-your-custom-tridion-content-delivery-code. public MyStorageExtension(String storageId, EntityManagerFactory ...

View answer
Session preview returns error: invallid null link
Accepted answer
4 votes

Peter Kjaer and Bart Koopman gave the right hints. When I checked the POST request (using the 'Network' tab in Google Chrome), I saw the following: Some TemplateId's were 'null'. This is because that ...

View answer
After Content Migration Topology Type is not available
Accepted answer
3 votes

The solution was very simple. I created a new Business Process Type, based on the Topology Type of the Development environment and added that to the publication. So publishing works now. Next step is ...

View answer
Storage Extension - exception in DAO construction
Accepted answer
3 votes

FOUND IT! It has cost me (and you) a lot of time, and the issue was indeed not in the code / configuration itselves. The solution is so simple that I am almost ashamed to share it ... When exporting ...

View answer
DD4T 2.2 MultimediaField empty when using Model Service
Accepted answer
2 votes

The issue is now reported on GitHub. I found out that there are multiple issues when working with the DXA Model Service together with DD4T. There is an issue related to keywords and there seems also ...

View answer
Tridion 2013 SP1: Content Delivery .NET - Unable to locate java runtime
Accepted answer
2 votes

Finally found the solution. The other applications on the webserver were 64-bit applications. This application was 32-bit. So I had to install Java 32-bit. It didn't work at first time, because the ...

View answer
Broker query criteria to search all multimedia components in a folder
2 votes

I did some research and there is no such criteria to look for components in a certain folder. BUT in your case for multimedia components you should try: PublicationMultimediaPathCriteria criteria = ...

View answer
Error when doing request from Event Handler
Accepted answer
1 votes

These servers have restricted which TLS version can be used. Adding the following line of code fixed the issue: System.Net.ServicePointManager.SecurityProtocol |= SecurityProtocolType.Tls11 | ...

View answer
The stored procedure 'EDA_TRUSTEES_GETTRUSTEETOKEN_X' doesn't exist
Accepted answer
1 votes

We requested a copy of the Content Management DB, but our hosting supplier delivered a copy of the old 2013 SP1 installation. So this error happens when you restore a 2013 SP1 database in your SDL ...

View answer
2013 Licence Error - Can't create TDSXGit.Configuration
1 votes

I had the same issue after removing 'old' accounts from the server. The Content Manager snap-in was also unavailable, so this article pointed me in the right direction: https://stackoverflow.com/...

View answer
The request is not a valid WS-Federation protocol message
Accepted answer
1 votes

Finally we found the rootcause. The Web Application Proxy (WAP) is very strict in which kind of requests it accepts. According to the standards, a comma value is not allowed, see: https://curl.haxx.se/...

View answer
org.hibernate.StaleStateException in deployer log, incoming folder not cleaned up
Accepted answer
1 votes

Issue is solved! We discovered a deadlock on the brokerdatabase (at the same time the incoming folder was 'full'), caused by the following query: delete from REFERENCE_ENTRIES where PUBLICATION_ID=@...

View answer
Event System Tridion 2013 SP1 - Cannot find connectionstring
Accepted answer
0 votes

The solution was a combination of the above. I already used the '.dll.config' file for configuration (via a custom class ConfigurationHelper). But .NET wasn't able to recognize the connectionstrings ...

View answer
Unable to execute HTTP POST - Transport Service (after a lot of polling attempts)
Accepted answer
0 votes

I found a solution. This answer helped me: HTTP Deployer displays slow transport throughput on high latency networks. We are now using a SFTP deployer. Publishing still takes a few minutes but no ...

View answer