I get the above mentioned error when I open an item in SDL Tridion 2011 SP1. (Upgraded from 2009.).

I can open the CM GUI. The list with items shows normal. I can browse everything, but when I open an item (page, component, etc) I get this error. I checked tnsnames.ora, and it seems correct. I verified this by running tnsping.exe {servicename} and it gives me an Ok (both 32bits and 64bits).

The stacktrace of the error indicates that it has something to do with the CoreService:

Component: Tridion.ContentManager.CoreService
Errorcode: 0

StackTrace Information Details:
   at Oracle.DataAccess.Client.OracleException.HandleErrorHelper(Int32 errCode, OracleConnection conn, IntPtr opsErrCtx, OpoSqlValCtx* pOpoSqlValCtx, Object src, String procedure, Boolean bCheck)
   at Oracle.DataAccess.Client.OracleException.HandleError(Int32 errCode, OracleConnection conn, IntPtr opsErrCtx, Object src)
   at Oracle.DataAccess.Client.OracleConnection.Open()

And specifically with this call: /WebUI/Models/TCM54/Services/General.svc/GetItem So it seems that the General.svc service cannot find/resolve the connection name.

Any idea's what's possibly wrong / where to look further?

I already tried/verified this: 1) Made sure that the correct tnsnames is used (how else would the list with publications show anyway?) 2) Verified the servicename in tnsnames.ora 3) Checked permissions on the oracle home folders (32bits and 64bits) 4) Repaired the installation 5) Disable loopbackcheck

Any help appreciated :)

(Tridion 2011SP, Oracle)

2 Answers 2


Sounds like a 32 x 64 bit Oracle client issue. Some of the lists retrieved by the CME use the CoreService (x64) while opening individual items (not all, but most) still use COM.

The TCM54 in the URL you mention means this call is going through the COM/TDSE bridge, which indirectly means it's using the 32 bit client.

I would try re-installing the Oracle client, making sure you're using the correct version as specified by Tridion in the release notes.

  • 1
    Thanks Nuno. I first installed the wrong version of the 32 bits client. Uninstalling this didn't quite uninstall everything (dll's weren't deleted from GAC). Manually uninstalling these dll's worked. After that I installed the version of both ODAC clients (first 64 bit, then 32 bit. Tridion 2011 SP1, HR2) and then everything worked as expected! Commented Aug 20, 2013 at 7:26

Check the spacing of entries in TNSnames.ora file. it looks simple however it shows same error TNS:could not resolve the connect identifier specified. We had a space at the start of entry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.