0

While trying to insert a Component Presentations in a Page, the window which opens after clicking 'insert' is not displaying Components or any other items?

Loading is not terminating as shown in the image. Please someone provide solution for this.

  • 1
    Have you performed regular database maintenance on the CM database, like updating statistics? – Bart Koopman Mar 5 '15 at 14:23
  • 1
    Have you tried clearing your browser cache? If the components have just been created, it could be that clearing the cache will show them for you. – johnwinter Mar 5 '15 at 14:25
  • 1
    start with reading the documentation on maintenance, and ask your DBA to maintain the database. If you are the DBA too, read up on proper database maintenance for high volume transactional databases. – Bart Koopman Mar 5 '15 at 14:30
  • 1
    I can't answer that based on the little info you have given, but I ALWAYS first suspect the database to be the issue of performance problems like this, since 9 out of 10 times the database was not well maintained and updating the database statistics usually solves it. – Bart Koopman Mar 5 '15 at 14:45
  • 2
    You have two messages in the top-right corner. Could you click on the red square that says "2" at the moment and see if there are any helpful error messages in there? – Peter Kjaer Mar 5 '15 at 15:49
3

Your question contains a lot of unanswered variables, like what database you have (Oracle or MS SQL Server) and what type of system it is (dev or prod) and whether it is properly maintained or not and how old it is, is the issue only occuring on some clients or also directly on the server etc. etc. etc.

So I'll give you a very generic answer that should give you a nudge in the right direction:

  1. if you just got assigned to be a SDL Tridion administrator, go to a sys admin training ASAP and learn about your new assignment. You can find details on the SDL website here http://help.sdl.com/services/education-certification/training-product/web-content-management/sdltridion-sysadmins-dba.html

  2. Read the documentation on maintenance of your system, that is your job now (assume it is never done, and it won't be done automatically unless you schedule something) http://docs.sdl.com/LiveContent/content/en-US/SDL%20Tridion%20full%20documentation-v1/GUID-94283420-8A51-4F2C-913E-B18455E58D74

  3. The documentation doesn't mention any specifics for MS SQL Server anymore, since that belongs in a standard MS SQL maintenance plan, but a trained DBA knows that there are some tasks he can better perform or schedule manually to keep DB performance up to par. You can read this old DB maintenance guide for some tips http://sdltridionworld.com/articles/MaintainingSDLTridiondatabases.aspx

  4. exec sp_updatestats is a useful command for MS SQL Server, read up on that. It is the one command I would blindly run on a MS SQL Server Tridion DB and it has performed magical results (the longer it takes to run the first time, the more magic it will give you, as that shows how long it hasn't been run)

  5. Truncating your transaction log on your database is the next best thing you can do. Especially for MS SQL Server, if it has never been truncated, chances are it is larger than 1GB which will bring the performance of your database to a standstill.

  6. After you are sure the issue can't be caused by your database, i.e. you have performed and scheduled regular maintenance for it, then the next thing you should look into is possible issues on the CM server or the network to it. Is this only occuring for some clients, is it also occuring when the browser is opened on the server itself directly etc.

1

Bala,

Try again with some other user login to the CMS. Sometimes it happened to me also. Or you clear your browser cache else clean up has to be done on the cms server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.