9

I am working on SDL Tridion 2013 SP1 and Alchemy version which i have downloaded is Alchemy4Tridion Version: 0.7.0.0 link.

I have downloaded the Alchemy4Tridion Developer Pack link and trying to install the demo version plugin but getting error attached is the screenshot

Please suggestenter image description here

Error in Debugger

http://domain.com/Alchemy/api/Plugins/Install Status Code :500 Internal Server Error

Debugger Log {message: "An error has occurred.",…} exceptionMessage:"Value cannot be empty. Parameter name: userName." exceptionType:"System.ServiceModel.FaultException1[[Tridion.ContentManager.CoreService.Client.CoreServiceFault, Tridion.ContentManager.CoreService.Client, Version=7.1.0.1290, Culture=neutral, PublicKeyToken=ddfc895746e5ee6b]]" message:"An error has occurred." stackTrace:" Server stack trace: at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Tridion.ContentManager.CoreService.Client.ISessionAwareCoreService.Impersonate(String userName) at Alchemy4Tridion.Plugins.Clients.AlchemySessionAwareCoreServiceClient.Impersonate(String username) at Alchemy4Tridion.Core.Web.RequestPropertiesContext.get_SessionAwareCoreServiceClient() at Alchemy4Tridion.Core.Web.RequestPropertiesContext.get_User() at Alchemy4Tridion.Core.Security.AlchemyAuthorizeAttribute.OnAuthorization(HttpActionContext actionContext) at System.Web.Http.Filters.AuthorizationFilterAttribute.OnAuthorizationAsync(HttpActionContext actionContext, CancellationToken cancellationToken) --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.Http.Filters.AuthorizationFilterAttribute.d__2.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter1.GetResult() at System.Web.Http.Dispatcher.HttpControllerDispatcher.<SendAsync>d__1.MoveNext()"

  • Please check the error in Debugger -> Console and/or Network Tabs and update the question with that. To open debugger right click any where in the window and click 'inspect'. – Saurabh Gangwar Feb 9 '16 at 9:41
  • Can you install any of the plug-ins from the web store? Maybe that particular plug-in was made for a previous version of Alchemy... – Peter Kjaer Feb 9 '16 at 9:45
  • Hi Peter, getting same error while installing the plug-in from web store as well.i just tried to install Republish plug-in from store but same error. 'Republish' Plugin Installation Failed! – Hem Kant Feb 9 '16 at 10:24
  • Check the server's Event Viewer for the actual error (could be in the Application log as warnings from ASP.NET). – Peter Kjaer Feb 9 '16 at 11:04
  • Your edit indicates that it doesn't impersonate properly. What kind of authentication do you have configured for your Tridion CME? – Peter Kjaer Feb 9 '16 at 17:28
5

I am guessing you are just trying to install a test/demo plugin to start with Alchemy.

I just tried to replicate the same error with the same versions, But it works fine for me.

What I did:

  1. Download the Developer pack from visual studio gallery.
  2. Create a demo project selecting "Starter Plugin Project" template.
  3. Build the project (without any changes) and navigate to the generated .a4t file.
  4. Drag and drop the file in alchemy window.

Please try above and check if there is still an error.

If you were not doing the same steps and setting the project with some other way/template. The first thing you needto make sure, that the project has "a4t.xml" file in it and at least has below configuration in it.

<?xml version="1.0"?>
<plugin xmlns:c="http://www.alchemywebstore.com/configuration/definitions" xmlns="http://www.alchemywebstore.com/">
  <name>MypluginName</name>
  <description><![CDATA[]]>My Plugin description</description>
</plugin> 

If the error is still there despite of having above, please check the error in browser debugger as I commented.

Hope it helps.

  • Okay, Can you copy the Error/Info and update the question? doing this you will get the better answers. – Saurabh Gangwar Feb 9 '16 at 12:32
  • I have updated my Question with Debugger message – Hem Kant Feb 9 '16 at 12:41
5

I had a similar issue and got around it by temporarily disabling Anonymous Authentication in my SDL Tridion site IIS. Once the plugin is installed, you should be able to re-enable the Anonymous Authentication.

anonymous authentication disabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.