5

We have a custom GUI Extension that was created for Tridion 2013 SP1 HR1, but when we've upgraded to Web8 are getting a strange error. Are there any core changes you need to make to extend the Ribbon toolbar in Web8 thats different thatn Tridion 2013 SP1 HR1?

What I see right nwo is that the following URL: http://tridion2013-tst.com/WebUI/Editors/CME/Views/Dashboard/Dashboard_v8.1.0.194.4_.aspx?mode=js

Throws the followign error:

Exception of type 'System.Web.HttpUnhandledException' was thrown.

The reference to configuration group "TranslateRibbon.Commands" cannot be resolved.

System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> 

System.Exception: The reference to configuration group "TranslateRibbon.Commands" cannot be resolved. at 
Tridion.Web.UI.Core.CachedJsGroup.ResolveResources(Dictionary`2 resources) at 
Tridion.Web.UI.Core.CachedJsGroup.get_Resources() at   
Tridion.Web.UI.Core.CachedJsGroup.GetLastModifiedTime(CachedResourceType resourceType, List`1 checkedResources) at 
....

The reference to 'TranslateRibbon.Commands' is my code, but before I go to far in debugging, wanted to see if there were general Web8 changes I needed to be aware of for extending the ribbon toolbar.


As an update, installing another existing 2013 plugin (From TridionWorld, PasteSpecial Extension) provides a similar error:

The reference to configuration group "" cannot be resolved.
System.Web.HttpUnhandledException (0x80004005): 
Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> 
System.Exception: The reference to configuration group "" cannot be resolved. at Tridion.Web.UI.Core.CachedJsGroup.ResolveResources(Dictionary`2 resources) at Tridion.Web.UI.Core.CachedJsGroup.get_Resources() at 

...........................
3

While I hate that this worked, and am cautious at calling this an 'answer' what did make both extensions funtional again in Web8 was to literally add an empty config group reference into the config fils:

<cfg:group name=""></cfg:group>

Again, seems more like a bug that this works around than a Fix, but for anyone stuck once i added that into my config file both plugins I was having issue with worked perfectly fine.

  • It might have let you show the extension but the extension functionality can not work with the empty group tag. Check you functionality please. – Rakesh Choudhary Aug 31 '16 at 6:42
  • You've just saved me hours (on top of the hours I've already spent trying to debug this) - thank you! Is there any theory about why this works? I have two Javascript <cfg:commandset> nodes defined, but other than that, nothing is different to my other GUI extensions that just work! Also worth noting for anyone else with this problem, is that I already had one <cfg:group> element, so I just added this empty one beneath it. – Jonathan Williams Jun 7 '17 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.