3

We recently upgraded to web 8.5 from Tridion 2013 SP1.
The CME search for a text is returning following error

(80040356) Unable to retrieve search results
Error occured while processing the request: Not Found.
The remote server returned an error: (404) Not Found.

The remote server returned an error: (404) Not Found.

When I try to reindex the searches it runs but I see lot of error in Event Viewer.

Unable to index item: tcm:xx-xxxxxx. <html><head><title>Apache Tomcat/7.0.39 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - /tridion/update</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>/tridion/update</u></p><p><b>description</b> <u>The requested resource is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/7.0.39</h3></body></html>


Component: Tridion.ContentManager.Search.Indexing
Errorcode: 854
User: NT AUTHORITY\SYSTEM

StackTrace Information Details:
   at Tridion.ContentManager.Search.Indexing.SearchIndexingEngine.ThrowIndexingException(String hostUrl, TcmUri subjectId, WebException e)
   at Tridion.ContentManager.Search.Indexing.SearchIndexingEngine.AddToIndex(TcmUri subjectId)
   at Tridion.ContentManager.Search.SearchIndexer.QueueMessageHandler.HandleMessage()

Are we missing anything? I have validated the Search Settings in MMC, web.xml in solr-tomcat\conf folder. Please let me know if you have any solution.

3

Seems to look like your CMS Solr instance not running.

Try to Troubleshoot the Search by following steps:

  1. Check if the Tridion Content Manager Search Host service and the Tridion Content Manager Search Indexer service are running
  2. Check if there any errors in the tomcat [Tridion-Home]\solr-tomcat\logs\catalina.xxxx-xx-xx.log
  3. Check this URL inside the CMS server http://localhost:8983/ by using your configured environment MTSUsername credentials
  4. Try running Sync-TcmSearchIndex from Powershell and see whether it's indexing or not by running Get-tcmqueueinfo to check the count of the Search queue
  5. Go to your SDL Web Content Manager console and then go to Search setting
  6. Check the Query Engine settings and Indexer service settings are correctly configured as Host: http://localhost:8983/tridion User: your environment MSTUser

I hope helps to troubleshoot your environment and keep it posted here.

1

Additionally,ensure that on your CMS server, there is a User Group named - SDLSearchUsers - and your MTS User (or the user with which your SDL Tridion Content Manager DCOM+ Application is running) is a part of this group.

These group settings although get set during the installation, but may get changed as per the IT policies or in case you have opted to change your MTS user.

The below screen shot may give you an idea:

enter image description here

  • Thank you Pankaj. I had verified this configuration as part of my investigation. – Rakesh Choudhary Feb 22 '18 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.