4

Tridion doesn't return items from the CMS Search - it always returns "There are no items in this view".

I have tested with a word in Search Term input and with a type search and it always returns "No results".

I have executed the Powershell command: (Get-TcmRepository).ID | Sync-TcmSearchIndex -verbose and the results indicate indexing is happening:

enter image description here

Next, I've tried renaming the folder solr-data (C:\Tridion\Search\solr-data) and executing the above command again and I see the folder gets created again.

Following this, I've restarted the Search Indexer and Search Host Service but the result is the same: "No results".

In another post, I learned that I could try to repeat the method previously described and execute the command Get-tcmqueueinfo to see the elements that it was necessary to reindex, returning the following result:

enter image description here

When the results in Search Queue row shows 0 - I've restarted the Search Indexer and Search Host Service but the result is the same: "No results".

Can anybody help me?

3

Try to Troubleshoot the Search by following steps:

  1. Check if the Tridion Content Manager Search Host service and the Tridion Content Manager Search Indexer service are running
  2. Check if there any errors in the tomcat [Tridion-Home]\solr-tomcat\logs\catalina.xxxx-xx-xx.log
  3. Check this URL inside the CMS server http://localhost:8983/ by using your configured environment MTSUsername credentials
  4. Try running Sync-TcmSearchIndex from Powershell and see whether it's indexing or not by running Get-tcmqueueinfo to check the count of the Search queue
  5. Go to your SDL Web Content Manager console and then go to Search setting
  6. Check the Query Engine settings and Indexer service settings are correctly configured as Host: http://localhost:8983/tridion User: your environment MSTUser
  7. Additionally, ensure that on your CMS server, there is a User Group named - SDLSearchUsers - and your MTS User (or the user with which your SDL Tridion Content Manager DCOM+ Application is running) is a part of this group.

These group settings although get set during the installation, but may get changed as per the IT policies or in case you have opted to change your MTS user.

I hope helps to troubleshoot your environment and keep it posted here.

  • Thank you Velmurugan. I'll try to do exactly what you say and I'll give you an answer. – Sergio Alonso May 30 '18 at 7:40
  • Thank you Velmurugan, it worked for me!!! – Sergio Alonso Jun 12 '18 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.