In our current Tridion 9.5 setup, we're using DD4T to retrieve pages. There are occasions when, on the server, we get in a state where the content returned is NULL. Even if that same URL was requested without an issue before. It's also not very clear how to get out of the situation. A restart of the IIS website did the trick 1 time, but not the other. Last time, we changed a line in the web.config (something irrelevant) and we started receiving the content again. Most likely the restart of the application pool was the actual trigger to get unblocked, but when restarting it manually before it didn't work.

We're unable to reproduce the issue using local code.

A GraphQL request in Postman, fetching the same content does return content.

Any ideas as to why this can happen or what we should definitely look into?

The DD4T packages we're using:

  • DD4T.Core => 2.5.0
  • DD4T.DI.Autofac => 2.5.0
  • DD4T.Model => 2.6.0
  • DD4T.MVC5 => 2.5.1
  • DD4T.Providers.Tridion9.5.CIL => 2.5.0

In code we call DD4T.MVC.Controllers.DD4TControllerBase.GetPage("url")

  • Welcome to Tridion Stack Exchange, Kenny! Interesting question. Are you able to get any logs and specifically a stack trace related to that request? Without knowing more this seems like a caching issue of sorts, either with DD4T or the underlying Content Delivery criteria filter calls its making in the Content Interaction Libraries (as noted in the tags). Commented Jan 31 at 22:44

1 Answer 1


Generally speaking there is nothing in DD4T which could cause this. DD4T is a very thin wrapper around the CIL, and just passes requests through. You could try to make a request with the CIL (e.g. with PageContentAssembler.GetContent) and see if that works.

Other questions:

  • Are you using the CIL or in-process?
  • Do you have a single content service or multiple with a load balancer?
  • Are you using the correct DD4T provider for your Tridion version?
  • Do you have DD4T caching enabled at all?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.