0

While trying to expand any publication in CME, I am getting following error:

Failed initializing the External Content Library with id adam. One or more errors occurred. There was an error reading from the pipe: The pipe has been ended. (109, 0x6d). The read operation failed, see inner exception. There was an error reading from the pipe: The pipe has been ended. (109, 0x6d). There was an error reading from the pipe: The pipe has been ended. (109, 0x6d).

StackTrace Information Details: at Tridion.ExternalContentLibrary.DomainModel.MountPoint.GetStubSchemaId(Int32 publicationId) at Tridion.ExternalContentLibrary.DomainModel.UserContext.InitializeMountPoints(IEnumerable1 eclUris) at Tridion.ExternalContentLibrary.DomainModel.UserContext.GetMountPoints(Int32 publicationId) at Tridion.ExternalContentLibrary.Service.EclService2012.GetList(String parentItemId, Int32 pageIndex, EclItemTypes itemTypes, IEnumerable1 basedOnSchema) at SyncInvokeGetList(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at Tridion.ExternalContentLibrary.Service.TransactionSupportInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

Is there any configuration that I am missing due to which I am getting this error?

Please note, I tried connecting to multiple Adam servers however getting the same error.

1
  • 1
    First of all it would be useful to know more details about your setup, which or what Adam ECL connector do you have installed on your server (is it the one from SDL or is it a custom built one)? Has it worked fine before? If so, then it is most likely not the configuration but more something in the connection, maybe the external server is not reachable anymore or some certificates have expired. But without more detail any answer you will get will be a shot n the dark. May 6, 2014 at 7:47

2 Answers 2

1

I have recently done ADAM integration, i was able to get the content etc without any issue. Please validate your ExternalContentLibary.xml file for following

 <MountPoint type="AdamProvider" version="*" id="Adam" rootItemName="Adam">
            <StubFolders>
                <StubFolder id="tcm:18-527-2" />
            </StubFolders>
            <PrivilegedUserName>domain\username</PrivilegedUserName>
        </MountPoint>

you can also refer this link (Login required) for additional details.

0

The problem in my case was missing permission to the CM certificate for MTS User and Network Service account. After adding those permissions the connector started working without any issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.