1

We have two CM servers load balanced in our development environment. We upgraded Development environment from 2011 sp1 HR2 to 2013 sp1.

After the upgrade we are able to connect to webdav and browse the folders however we try to create new component or any other operation then it fails with error:

You do not have the permission

stack trace from event log:

No items found for WebDAV URL(s): /webdav/400_Publication/Building%20Blocks/.../Test.xml. Component: Tridion.ContentManager.CoreService Errorcode: 512 User: NT AUTHORITY\NETWORK SERVICE StackTrace Information Details: at Tridion.ContentManager.UrlConversion.Convert() at Tridion.ContentManager.Session.GetTcmUri(String uri) at Tridion.ContentManager.Session.GetObject(String uri) at Tridion.ContentManager.CoreService.CoreServiceBase.GetSubject(String id, ReadOptions readOptions) at Tridion.ContentManager.CoreService.CoreServiceBase.Read(String id, ReadOptions readOptions) at SyncInvokeRead(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at Tridion.ContentManager.CoreService.CoreServiceInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

Please note, I am administrator on Development environment.

Please suggest if I am missing something.

  • Look to Tridion Event log and copy errors from there (with Stack trace). – Syav4eg Aug 18 '14 at 8:10
  • Added event log stack trace. – Hiren Kaku Aug 18 '14 at 17:05
  • So which exactly error do you have ? "No items found for WebDAV" or "You do not have the permission" ? It seems it is different errors (due to different reasons) – Syav4eg Aug 18 '14 at 18:14
  • No items found for WebDAV URL – Hiren Kaku Aug 18 '14 at 18:45
1

With the upgrade of 2013 sp1 for webdav to work, following steps have to be performed on client machine which are accessing webdav url

  1. Open registry (regedit)
  2. Go to location: HKEY_LOCAL_MACHINE -> System -> Current ControlSet -> Services -> WebClient -> Parameters
  3. Open BasicAuthLevel value to 2.
  4. Close the registry
  5. Restart the client machine
  6. After restarting try to connect to webdav.

It should work! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.