1

We are using Tridion 2011 SP1 in combination with Tridion UI 2012.

I had definied a bunch of content types in the publication properties to be used inside the UI interface. At one point a referenced component was deleted, which apparently is possible, even though it is referenced inside the Content Types overview.

But, ever since when exporting and importing using the Content Porter I have been getting the error:

Unable to resolve WebDav URL for item "tcm:1-2345". referenced in application data. It will be ported as is.

It will let me export and import, but with errors...

The whole Tridion UI 2012 application seems to be based on configs and webdav urls stored as some sort of data file, but I cannot seem to update, or clear this error.

  • 1
    It's probably in App Data. There is a Powertool that let's you inspect it. – Nickoli Roussakov Nov 4 '14 at 11:13
  • I can see it sitting there in the Item XML view of the publication (using the Powertool), but I can't get rid of it. – Hendrik Beenker Nov 5 '14 at 8:48
  • The I would suggest a Powershell script or a quick and dirty Core Service program to remove it via the API. It is a simple key/value pair concept. – Nickoli Roussakov Nov 5 '14 at 13:06
1

Nickoli Roussakov helped me look in the right place, but the solution to the issue is rather cumbersome. I solved it without creating script, because I wanted to show the content editor how to solve the issue when it occurs again (and why it happened).

The only way to completely reset the Content Type Mappings of a Page Template is to select the Inherit Settings from Parent checkbox for the page template in the settings. Save these settings, double check if the page template is gone using the Powertool' Appdata Inspector (or XML view)

enter image description here

After this you will have to set the predefined content types again and the bad reference will be gone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.