5

We are starting to use TRI and we saw that we have to declare for the mapping of the schemas.

In documentation we see:

"Add a system wide (global) application data containing the different vocabularies you will use:"

I forgot to copy the Tridion Reference Implementation.xml file into %TRIDION_HOME%\config\ImportExport\ApplicationData and now, we have to import manually.

  • Did you copy the Tridion Reference Implementation.xml file into %TRIDION_HOME%\config\ImportExport\ApplicationData on your CM server before running the import.ps1 script? If not you will not have imported the application data, in that case, please edit your question and add this information in there so I can adjust my answer. – Bart Koopman Mar 9 '15 at 7:45
4

Application Data is stored in the CM database and accessible via the API only.

I've created an example custom page that can be used to manage the vocabularies which can be found on Google Code: https://code.google.com/p/sdl-tridion-world/source/browse/#svn%2FAppData%20Custom%20Page%2Ftrunk

If I remember correctly there is also something mentioned about it in the documentation.

As a start I would install the custom page and view its source for details about how it works and what it does.

Btw. You don't have to add a new vocabulary for mappings, you can also use the existing vocabularies (the default TRI or schema.org).

update

Considering you forgot to copy in the Application Data Configuration (with the Application data ID's), you have a couple of options:

  1. You could rerun the import script and let it update all exising content including the application data. (check the documentention and make sure you perform steps 1-3 now) This is a good option, but if you have already modified a lot of the content or made changes you don't want overwritten, then you need to check out option #2.

  2. Manually set the application data, starting with the vocabulary. This is best done by installing the custom page mentioned above, and open it. Add the following in the Vocabularies field:

    <vocabularies>
      <vocabulary prefix="tri" name="http://www.sdl.com/web/schemas/core"/>
      <vocabulary prefix="s" name="http://schema.org"/>
    </vocabularies>
    

    And press the Update button to save it. Then under Schema mapping select the Article Schema and add <typeof>s:Article</typeof> in the field next to it and press Update, Select the Image Schema and add <typeof>s:MediaObject</typeof>, and do the same for the Link Schema with the value <typeof>s:Thing</typeof>.

  3. Last option you have is drop all your Publications and reimport from scratch.

  • Thank you, Bart. When we start the application is loading the _all.json file and is mapping the schemas using the vocabularies. In article, the field dateCreated is using the vocabulary with prefix "s", and this prefix is not included in the default configuration. – Guskermitt Mar 8 '15 at 10:45
  • @Guskermitt are you talking about the prefix in the Entity class? – Bart Koopman Mar 8 '15 at 16:57
  • yes. when is trying to map the schema is failing because the unique vocabulary that we have is "tri", but the schemas has "tri" and "s". – Guskermitt Mar 8 '15 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.