I have a problem i one of my environments. When I am logged in XPM, I can't see the target icon neither targeted regions in my properties page. But ST works because i can see the promotion selected.

In other environments I can edit promotions from XPM.

enter image description here enter image description here

here is my HTML code:

<html lang="es">
        <meta name="viewport" content="width=device-width, initial-scale=1">
            <meta charset="utf-8">
                <title>Test st</title>
                    <div class="nojs">Javascript must be enabled for the correct page display</div>

                <!-- Start Promotion Region: {"RegionID": "Carousel" } -->

                    <!-- Start Query: {
    "RegionID" : "Carousel",
    "MaxItems" : 1,
    "Experiments" : [
    "Promotions" : [
            "PromotionID": "752abc11-884a-40b5-80b3-ab5ec4ddba80",
            "PromotionTitle": "Test Carousel",
            "IncludedInPage": true,
            "Items" : [
                { "ComponentID": "tcm:164-81776-16", "ComponentTemplateID": "tcm:164-81775-32", "IncludedInPage": true }

                        <!-- Start Promotion: { "PromotionID": "752abc11-884a-40b5-80b3-ab5ec4ddba80", "RegionID" : "Carousel"} -->

                            <!-- Start Component Presentation: {"ComponentID" : "tcm:164-81776", "ComponentModified" : "2015-06-25T09:19:55", "ComponentTemplateID" : "tcm:164-81775-32", "ComponentTemplateModified" : "2015-07-23T14:05:59", "IsRepositoryPublished" : true } -->
                                <!-- Start Component Field: {"XPath":"tcm:Content/custom:sys_literal/custom:value[1]"} -->ST works</span>

                        <!-- End Promotion -->

                    <!-- End Query: -->

                <!-- Page Settings: {"PageID":"tcm:164-82353-64","PageModified":"2015-06-24T17:44:33","PageTemplateID":"tcm:164-82356-128","PageTemplateModified":"2015-07-27T13:38:44"} -->
                <script type="text/javascript" language="javascript" defer="defer" src="http://SES000900-1667/WebUI/Editors/SiteEdit/Views/Bootstrap/Bootstrap.aspx?mode=js" id="tridion.siteedit"/>

When I put this sentence in chrome console with editor.aspx frame, Tridion.Web.UI.Editors.SmartTarget.Model.ListTargetedRegions.listTargetedRegions.getXml() appears this error enter image description here

Can anyone helps me please?


  • What versions are you using (CM and Browser). And are you using the same version(s) in 'the other environments'? Jul 30, 2015 at 12:17
  • First step is to check if the XPM markup is present and valid. If possible, please post the HTML source from the browser (replacing any sensitive data with dummy text). Jul 30, 2015 at 12:31
  • Hello, thanks for your answers! I use Tridion 2013 SP1 and Firefox 38.0.5, and I use the same version i the resto of environmets. Jul 30, 2015 at 13:07
  • I recognize this. I've already given all of my input through Customer Support already, so I doubt I'll be able to come up with more without additional information. Jul 30, 2015 at 14:23
  • 1
    The HTML doesn't seem to be completely valid. Could you try using validator.w3.org/check to fix the validation errors and see if that fixes the issue? Jul 31, 2015 at 11:48

2 Answers 2


Finally I have resolved my issue, the problem was a configuration in the Publication Targets.
I created 2 similar Publication Targets (Previsualization and PrevisST), both had the same webservice_preview url,and both use the same URLs to access but only PrevisST had filled Targeting layer.

When I tried to modify my page from XPM, the default target selected was Previsualization whose Targeting settings weren't configured.

I have solved the issue by removing targeting layer settings from PrevisST and filling in Previsualization.

I hope to help someone with the same problem.



Is there any information being shown in the logs of Odata, and are the configurations in line for the Odata service.

  • cd_ambient_conf.xml has the SmartTarget cartridge ?
  • smarttarget_conf.xml has the regions and is connecting to the right server ?
  • 1
    that is my preview_webservice's cd_ambient_conf.xml <Cartridges> <Cartridge File="cd_webservice_preview_cartridge.xml"/> <Cartridge File="smarttarget_odata_cartridge_conf.xml" /> </Cartridges> Preview_webservice's smarttarget_conf has the regions and conecting to the right server. Jul 31, 2015 at 10:23
  • 1
    This doesn't seem to be an ADF or SmartTarget, but rather something with the client-side markup for the regions. Aug 2, 2015 at 8:50
  • I use the same templates in both environments, I think there will be a conection with Fredhooper, but i can´t find the error... Thanks! Aug 5, 2015 at 8:56
  • Hi Jose, Have you got the solution of this problem. I am facing the same issue in Development environment. First one, some times smart target regions are not showing in page properties in XPM and also component fields are not showing editable. When I refresh the page 1-2 times it start working correctly.Second one, broken line showing in your screenshot in XPM. If you already got the solution please share.. Aug 11, 2015 at 14:22
  • I'm still getting this error, I'm searching in .net fusion log for error in some dll. I hope to resolve this problem as soon as possible. Aug 12, 2015 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.