4

I'm new to this Tridion and DD4T development and I need some help on XPM.

We're currently doing a POC using DD4T version 2.0.2. We are trying to implement inline html editor using XPM tag.

The view and editable tags seem to be fine (They're outputting json in the HTML if we view source) but if we add <xpm:init page="${pageModel}" /> before the </body> then it stops rendering at that point and no JSON is output for the page.

Could someone please tell me if I did something wrong or confirm that the <xpm:init> tag works in the version 2.0.2?

dd4t.properties

xpm.enabled=true
xpm.cmsUrl=http://1.2.3.4/

Here is the code:

enter image description here

  • You should see an Exception in the logs somewhere. Can you post that? – Raimond Mar 4 '16 at 10:52
  • 1
    There were a couple of bugs in the implementation. These are now fixed. See github.com/dd4t/dd4t-2-java/issues/44. Release 2.0.5 is expected shortly. – Raimond Mar 5 '16 at 14:44
  • Hi Raimond, it seems that you fixed the issue already so I don't need to post the logs. Do you know the schedule for 2.0.5 release? Thanks – Jon S Mar 7 '16 at 22:03
  • I need to run some tests, but other than that it's ready for release. Expect something this weekend. – Raimond Mar 8 '16 at 8:41
  • Hi Rainmond, I just created another issue. I'm not sure if this relate to the other one. Could you take a look? <tridion.stackexchange.com/questions/14117/…> Thanks – Jon S Mar 8 '16 at 16:05
1

From comment:

There were a couple of bugs in the implementation. These are now fixed. See https://github.com/dd4t/dd4t-2-java/issues/44. Release 2.0.5 is expected shortly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.