6

This when I see it:

  • Imported Contacts from Audience Manager Address Book using CME UI, which is of size 28MB.

  • While importing the same file back to another Address Book there, I get Error

    Unable to recongize the upload state data
    

I am able to import the contacts for the small size files < 3-4 MB.

Here is what I tried so far:

  • Increase Timeout settings for Core Service in all the required places.

  • Had set <httpRuntime maxRequestLength="1073741824" /> and <requestLimits maxAllowedContentLength="1073741824"/> so you can see its almost 1GB. This is done for both Core Service as well as Tridion.

  • Increase Idle Timeout setting on the Load balancer as well from 60 sec to 10 Min.

But with all the above changes no luck.

Can anyone suggest what else could be the possible reason to have it not fixed with all the above changes?

  • Just pointing out that maxRequestLength should be in KB (i.e. 1048576), so the value you have there is actually 1TB, not 1GB. maxAllowedContentLength is indeed in bytes. May not be related to the error, but it seems incorrect :) – Dave Forber Sep 28 '16 at 15:13
  • I hope it is, but that is in bytes according to SDL Docs. – Vikas Kumar Sep 29 '16 at 6:51
4

The default file size allowed on upload is roughly 30 MBs. So I don't think you are hitting the limit there.

It seems more likely that you have a load balancer and have not enabled sticky sessions for the Content Manager Explorer. So it sometimes sends you to a different server when the upload completes and thus cannot find the file that was uploaded.

Usually you can find out the exact cause of the error by looking in the Application event log for "warnings" from ASP.NET.

  • Thanks Peter. I will have a look at that and comment here. – Vikas Kumar Sep 29 '16 at 11:42
3

Okay so this was not the sticky session stuff, I had to make changes to 2 files and it worked.

  • {TRIDION_HOME}\web\WebUI\WebRoot\Web.config
  • {TRIDION_HOME}\web\Web.config

The entries are as below:

<system.web>
   <httpRuntime  executionTimeout="100000" maxRequestLength="1073741824" />
</system.web>

And

<system.webServer>
    <security>
        <requestFiltering>
    <requestLimits maxAllowedContentLength="1073741824"/>
        </requestFiltering>
    </security>
</system.webServer>

Remmeber executionTimeout is important to allow appropriate time to have the upload session working.

Note:

  • executionTimeout="100000" is in seconds
  • maxRequestLength="1073741824" is in Bytes which is close to 1GB

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.