I'm using SDL Web 8, and it uses LDAP authentication. I try to set up DXA 1.5 on the environment.

But when following error occurs when importing publication by cms-import.ps1.

PS C:\Users\Administrator\Desktop\SDL DXA Java 1.5\cms>  .\cms-import.ps1 -importType all-publications -cmsUrl "http://localhost:81" -cmsUserName "ldap_domain\user" -cmsUserPassword "user" -cmsAuth Basic -Verbose
VERBOSE: Performing the operation "Import DXA Core items" on target "http://localhost:81".
VERBOSE: Temp folder is 'C:\ProgramData\DXA\'
VERBOSE: Initializing Core Service client using folder 'C:\Users\Administrator\Desktop\SDL DXA Java
VERBOSE: Initializing Import/Export using folder 'C:\Users\Administrator\Desktop\SDL DXA Java 1.5\cms\..\ImportExport'
VERBOSE: Getting Core Service Client with type 'Service' for CMS URL 'http://localhost:81/' ...
VERBOSE: Using Basic authentication with CMS user name: ldap_domain\user
VERBOSE: http://localhost:81/webservices/CoreService2013.svc/wsHttp
Get-CoreServiceClient : Exception calling "GetCurrentUser" with "0" argument(s): "Secure channel cannot be opened
because security negotiation with the remote endpoint has failed. This may be due to absent or incorrectly specified
EndpointIdentity in the EndpointAddress used to create the channel. Please verify the EndpointIdentity specified or
implied by the EndpointAddress correctly identifies the remote endpoint. "
At C:\Users\Administrator\Desktop\SDL DXA Java 1.5\cms\cms-import.ps1:103 char:22
+ $coreServiceClient = Get-CoreServiceClient "Service"
+                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Get-CoreServiceClient], MethodInvocationException
    + FullyQualifiedErrorId : SecurityNegotiationException,Get-CoreServiceClient

It seems connection to CoreService Web service failed by some authentication problems.

LDAP authentication succeeds when logging in to SDL Web 8, and another custom program using CoreService is working normally.

I set up LDAP on SDL Web 8 by SetupLDAP.ps1. Is any other configuration required?

  • Hirokazu, were you able to resolve this issue? I am experiencing exactly the same issue. Commented Nov 3, 2016 at 21:59

1 Answer 1


By default, the cms-import.ps1 script uses Windows authentication and uses the current Windows user to log in to the CMS.

For LDAP authentication, you should specify -cmsAuth Basic and specify the CMS user name and password as -cmsUserName and -cmsUserPassword parameters, respectively.

UPDATE: I see you already specified that. However, the error message hints at an HTTPS issue. Indeed, LDAP auth is typically combined with HTTPS (since with Basic auth, the password will be sent over the wire in almost plain text).

In case the Core Service is configured for HTTPS, you should ensure your cmsUrl parameter starts with https:

  • I have the same issue with CME/Core Service running under HTTP and LDAP configured to use SSL. Commented Nov 3, 2016 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.