5

Using the E-Commerce framework's Fredhopper ECL Connector I get this error message in the CME when I open the "Fredhopper E-Commerce" mount point and browse to Categories or to Products.

enter image description here

Unable to get the list of items An item with the same key has already been added. at Tridion.ExternalContentLibrary.UI.Model.Services.GeneralImpl.GetList(String id, Int32 pageIndex, Filter filter, Int32 columns) at Tridion.ExternalContentLibrary.UI.Model.Services.General.GetList(String id, Int32 pageIndex, Filter filter, Int32 columns) at SyncInvokeGetList(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at Tridion.Web.UI.Core.Extensibility.DataExtenderOperationInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet) Hide Details

Things I checked:

  • Event Viewer: No related messages
  • ECL configration: Looks allright
  • Fredhopper URL: Is accessible from the CM server
  • Removed all ECL stub components and the stub schema: This is most likely not related (stub components are not created when browsing though the ECL mountpoint), but it did prove that the ECL mechanism is doing something: the ECL stub schema got recreated.
  • I don't think it's actually a problem in ECL, but rather that some data extender isn't handling the request correctly. I would try to remove other editors/models to see which one is incompatible. My reasoning is that this is a classic dictionary error and the ECL model code that the stacktrace is pointing to isn't using any dictionaries. – Peter Kjaer Nov 24 '16 at 14:40
1

The ECL thing turned out to be a problem in the E-Commerce provider. After setting some facets in Fredhopper the problem was resolved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.