1

I have the same issue as stated here: Item of type 'MappingData' can not be saved. Unable to connect to 'net.tcp://localhost:2660' using authentication type 'Windows' and here https://gateway.sdl.com/apex/communityknowledge?articleName=Item-of-type-MappingData-cannot-be-saved. But for me the solutions do not work.

So my impersonation user is NT AUTHORITY\NETWORK SERVICE:

enter image description here

I also have this user in my TRUSTEE table :

enter image description here

I get the same error when I run the Add-TtmMapping command via PowerShell

When I check Event Viewer I also see every 10 seconds the following error, related to the NT AUTHORITY\NETWORK SERVICE account

enter image description here

Is there maybe an issue that NT AUTHORITY\NETWORK SERVICE cannot be used as a valid impersonation user?

3

Try the following steps to fix your issue:

  1. To ensure currently logged in user Member of Topology Manager Administrators group to read and edit Topology Manager environments configuration.
  2. Run this PowerShell cmdlet Get-TtmCmEnvironment to verify CMS URL and Credentials are configured correctly to your environments details.

Example:

    PS C:\Users\vagrant> Get-TtmCmEnvironment
CoreServiceRootUrl : net.tcp://localhost:2660 WebsiteRootUrl : http://VAGRANT-2016:80 CoreServiceCredentials : "AuthenticationType":"Windows", "UserName":"VAGRANT-2016\MTSUser", "Password":"********" Id : Tridioncm_localhost ExtensionProperties : {}

  1. Double check MTSUser exist in Content Manager Trustees table, It uses the Core Service URL and credentials specified in above CmEnvironment entity (in Topology Manager). The credentials should be of an existing, enabled User account (with sysadmin privileges)

  2. Double check CMS URL and User Credentials are configured correctly to your environment specific, Need to update using this PowerShell cmdlets.

Set-TtmCmEnvironment -AuthenticationType Windows -UserName "VAGRANT-2016\MTSUser" -Password "xxxx" -WebsiteRootUrl http://VAGRANT-2016:80

  1. In your CME server System Environment variables ensure your envivironemnt variable TRIDION_CM_ENVIRONMENT_ID matches your TtmCmEnvironmentId, eg: Tridioncm_localhost

  2. If you have a scale-out CME / Publisher servers environment step 1 to 5 should be same on all the servers.

enter image description here

I hope it helps.

  • Hi Velmurugan, I think you pointed out the issue. As User account for the CoreService the MTSUser is defined, while it tries to connect as NETWORK SERVICE. When I try to change the user to NT AUTHORITY\NETWORK SERVICE, it gives the same error. So I think the other option is to Add the MTSUser as impersonation user, is that correct? – Peter van der Lugt Feb 22 at 8:46
  • AFAIK, Not required to add MTSUser as impersonation user in SDL Console. – Velmurugan Feb 22 at 9:22
  • NOW IT WORKS! I was confused because the error in Event Viewer was about the NT AUTHORITY\NETWORK SERVICE user. But when I readded the MTSUser as Admin I was able to add the mapping. Do you know where the error comes from? – Peter van der Lugt Feb 22 at 9:47
  • Good to know it works now :-), Looks like from your batch service? – Velmurugan Feb 22 at 9:55
  • Also the Topology Manager was throwing that error (6 lines below in the Event Viewer screenshot). But also of the NETWORK SERVICE account. So not sure why adding the MTSUser as admin fixed this issue. But I'll accept your answer because it is great information to debug the issue. – Peter van der Lugt Feb 22 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.