2

We have implemented DXA hotfix 2.0.1 with .net and Web 8.5 recently and also enabled ActiveMQ with it, by following steps mentioned here

Mostly, it's going fine and the cache gets invalidated for most of the changes like page, component etc. The only area where it is not working is when we access dynamic components.

Even if we reduce the cache duration to 5min, the only way to clear the cache is to restart the content service. We have checked the questions present in stack exchange like this but we still have the same issue.

Any help would be appreciated.

  • Which DXA 2.0.1 hotfix are you referring to? DXA Model Service or DXA.NET Framework? – Rick Pannekoek Mar 15 at 10:44
  • We are referring to DXA Model Service hotfix. – GJin Mar 15 at 12:11
  • 1
    Could you please explain your caching settings in your model service and content service and web app? To be aware that model service hotfix which you have using bit changed the architecture it's in-process model service, from modelservice it will never communicate to content service for getting content. instead, it will directly communicate broker DB and get the content, be aware that there is 2.0.2 model service hotfix - github.com/sdl/dxa-model-service/releases, based on your settings review will explain and recommend the correct cache settings for DXA model service caching. – Velmurugan Mar 18 at 7:56
  • Yes Velmurugan, we were aware of the changes to DXA model service after the hotfix. But we have certain functionalities for which the content was getting updated only after restarting content service. Anyway we did find the issue in our settings which i will update as an answer in case it helps someone else – GJin Mar 18 at 18:00
1

We later realized that we had issues with both static and dynamic components and were able to fix by doing the following:

  • When we install hotfix 2.0.1, SDL gives us with a default setting for cd_storage_conf. We made couple of updates to that. First is that they defined a queue size of 1024 which was not sufficient for us, so it can be either removed or it can be made higher which suits the environment. For us, we removed it altogether, the way its mentioned here
  • Also notice that the topic mentioned in the default configuration would be SDLWebCCS and the deployer still might have TridionCCS as topic. Change either to make it consistent
  • ActiveMQ then threw an "forbidden class" error which can be fixed by following steps here. Note that, the only solution that worked for us was to add the entry in cd_storage_conf. Adding entries in wrapper.conf didnt work for us.

After making these changes, we noticed successful invalidation messages being sent from deployer and being received by dxa model service (& content service) Our initial testing has been positive till now and we are in a process of testing extensively.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.