2

I've configured SI4T using a custom elastic search from this blog :

After completing the tutorial. I published a page, but nothing gets added to the elastic search index.

The logs are indicating that the content is only being removed when I publish. I'm thinking it may have something to do with the TBBS but don't want to go down a rabbit hole on this. Any help is appreciated!

Here are the log messages:

2019-05-23 15:04:17,087 INFO  [ProcessingAkkaSpringContext-akka.actor.default-dispatcher-47] ElasticSearchIndexer - Removing 1 documents in batches of 10

2019-05-23 15:04:17,087 INFO  [ProcessingAkkaSpringContext-akka.actor.default-dispatcher-47] ElasticSearchIndexer - Dispatching documents in 1 batches

2019-05-23 15:04:17,087 INFO  [ProcessingAkkaSpringContext-akka.actor.default-dispatcher-47] ElasticSearchIndexDispatcher - Removing tcm:15-1570-64 document from the elastic search Indexer

2019-05-23 15:04:17,114 INFO  [ProcessingAkkaSpringContext-akka.actor.default-dispatcher-47] ElasticSearchIndexer - Removing 1 documents of batch 1 had the following response: Deleting 1 document(s) had the following response: OK

2019-05-23 15:04:17,114 INFO  [ProcessingAkkaSpringContext-akka.actor.default-dispatcher-47] ElasticSearchIndexer - items to add size:  0

2019-05-23 15:04:17,114 INFO  [ProcessingAkkaSpringContext-akka.actor.default-dispatcher-47] ElasticSearchIndexer - Clearing out registers.

EDIT/UPDATE :

Using the si4t search index update to SI4T TBBs provided by Sayantan Basu in combination with creating a new page and publishing did the trick.

  • Are you using Sites 9 by any chance? – Sayantan Basu May 23 at 15:48
  • @SayantanBasu Yes I am. – Michael Poblacion May 23 at 16:18
  • Ok then It is a known issue. already submitted the updated code but I guess it will be merge in next few days. But in the meantime, you can download the template code and manually update the class. Here are the details for reference github.com/SI4T/SI4T/pull/21 – Sayantan Basu May 23 at 16:30
  • @SayantanBasu Thank you so much for the quick response and solution! I will implement and let you know how it goes. – Michael Poblacion May 23 at 16:33
  • I updated the details in the answer. – Sayantan Basu May 23 at 16:54
4

In Sites 9 Regions are newly introduced to structure the content on a page in a better way. So the page is having a new structure now. The idea is while publishing the page we need to handle this region on the SI4T template. You can find the change in the pull request https://github.com/SI4T/SI4T/pull/21 . It will be merged in the next release I guess.

So either you can update it manually Or you can find it in below repository where I updated the code already and using it with Sites 9.

https://github.com/justsayantan/SI4T-develop/tree/develop/tbbs

  • Ouch! Can you also create a GutHub issue for the DXA Search Module for this issue? – Rick Pannekoek May 23 at 18:03
  • I think your update was definitely necessary to pick up regions, but it didn't seem to solve the issue. Here's what I'm seeing from the logs: 2019-05-23 17:51:12,582 INFO [ProcessingAkkaSpringContext-akka.actor.default-dispatcher-117] TridionPublishableItemProcessor - No search data found. – Michael Poblacion May 23 at 18:28
  • Are you able to see the search index data while click on preview ? – Sayantan Basu May 23 at 19:09
  • 1
    In the template builder? Yes, I can see the index data being produced by the TBBs. That is what you mean right? – Michael Poblacion May 23 at 20:49
  • If you select the page and click on preview, then go to source tab and check the content, if it is there that means your updated search templates are properly working with your page template – Sayantan Basu May 23 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.