0

I am trying to upgrade Sites 9.1 to 9.5 in an AWS instance and, as part of that, I have done the following:

  • Installed the Add-on Service and I can hit the Adds-on URL.

enter image description here

  • Installed the Access Management Service as an IIS website and created a windows identity provider. I am able to hit the Access Management URL.

enter image description here

  • Enabled integration with the Add-ons Service and Access Management Service during the Content Manager installation and the installation completed successfully.

When I try accessing the Content Manager UI, I get the following error:

Cannot open database "Tridion_cm" requested by the login. The login failed.
Login failed for user 'WORKGROUP\EC2AMAZ-TUJ3HK0$'.

I tried granting access to the Trdion_cm database for WORKGROUP\EC2AMAZ-TUJ3HK0$ user, but there is no such user.

What am I missing with this? Do we need to grant access to any other user on the Tridion_cm database?

6
  • 1
    Looks like you are using integrated authentication for cm database. Did you try following steps from following page docs.sdl.com/816112/673783/sdl-tridion-sites-9-5/… Jan 25 at 9:14
  • @StefanKlasnic - Thanks for your reply! No, I am using Windows authentication though, which was working fine with 9.1. Jan 25 at 10:13
  • @Sabarish Senthilnathan , Just to understand , when you did the upgrade from 9.1 to 9.5 , did you use the AdministratorUserName and AdministratorUserPassword and not the Existing database users example TCMDBUser , if so What do you see on the Tridion Snap in for the DB settings and you had mentioned you did not use IntegratedSecurity
    – Anand NS
    Jan 25 at 10:43
  • 1
    Go to the SDL Console database section to see first what is the username is provided in the installation. if needed you can decrypt the TridionContentManager.config file double-checks the connection string that was provided.
    – Velmurugan
    Jan 25 at 13:04
  • Any updates on this @SabarishSenthilnathan did you try the options mentioned or you still facing the issue let us know
    – Anand NS
    Jan 27 at 7:34
2

I think the error message is confusing. Access to the tridion_cm database is failing, and because of that, the login for your User (WORKGROUP\EC2AMAZ-TUJ3HK0$) fails. This does not mean that the database connection makes use of your user's credentials, at least I hope not.

You should check the database credentials configured for the content manager. This should have nothing to do with the Access Management feature, which is used for User logins, and not for a service account such as is used for the database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.