0

Download DXA from: https://github.com/RWS/dxa-web-application-java/releases/tag/DXA_2.2

An error occurred while importing DXA publications with the command below:

'.\cms-import.ps1 -importType all-publications -cmsUrl "https://tridion.xxxxx.xxx" -cmsUserName "******" -cmsUserPassword "*******"'

Error message:

2021/11/18 14:09:23 <80> [Error] Tridion.ContentManager.InvalidUriException: No items found for WebDAV URL(s): /webdav/110%20DXA%20Site%20Type/Building%20Blocks/Framework/Developer/Templates/JSON.tptcmp.
at Tridion.ContentManager.UrlConversion.Convert()
at Tridion.ContentManager.IdentifiableObject.UpdateInternal(IdentifiableObjectData deltaData)
at Tridion.ContentManager.Session.GetNewObject(IdentifiableObjectData data)
at Tridion.ContentManager.ImportExport.AbortErrorHandler.Invoke[T](Func`2 function, LocalizableMessage message, Boolean retryAvailable, Boolean isCritical, UserReply additionalUserReplyOptions)
at Tridion.ContentManager.ImportExport.CreateImportAction.Perform(IdentifiableObjectData itemData)
at Tridion.ContentManager.ImportExport.Importer.ImportItem(WebDavUrl exportUrl, IList`1 dependentItemsChain, Dictionary`2 unresolvedDependencies, Boolean specialImport)
at Tridion.ContentManager.ImportExport.Importer.ImportItems(IList`1 items, Boolean specialGroupImport)
at Tridion.ContentManager.ImportExport.Importer.Import(String packageName)
2021/11/18 14:09:23 <80> [Information] Transactional import failed at 11/18/2021 2:09:23 PM(+0000). No changes were committed to Tridion Sites Content Manager.

However, it succeed when I tried the 4th time without changing anything. Any ideas on what leads to this error?

1 Answer 1

2

"Unresolved dependencies" ... do you have the three specific error messages - I wonder if each import brought in a dependency that was required until all dependencies where in place? The only other reason I could see it failing intermittently would be

  • access issue (network) access issue
  • content porter already running
    • perhaps it was running as a service in the background the first three times

    • but the error doesn't really lean to that

2
  • thank you, Dylan. The first 3 times failed with the same error mentioned above in Error message.
    – Emma
    Dec 15, 2021 at 13:28
  • As you can see in the log, the import is done transactional, meaning that if something goes wrong, the entire import is rolled back. So, I don't expect each attempt to change the state of the system. I cannot explain the observed behavior; I have never seen this happening myself, despite having observed thousands of imports. Dec 25, 2021 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.