7

I notice that when session preview is enabled for Experience Manager, my page is auto-published to my staging website when I click Finish Editing. When I disable session preview, it no longer auto publishes. Is it possible to configure this behaviour somewhere (for example if I do not want to auto-publish when using session preview, or do wish to auto-publish when not using session preview)?

5

No, there's no configuration for that.

However, the behavior is unrelated to Session Preview -- it will always attempt to Publish the item after it has been saved successfully. I'm not sure what scenario you are describing where it doesn't Publish - but maybe it was because there were no changes to save?

  • Thanks Peter - I am definately making changes, and its strange as I now tried some other pages, and they do auto-publish, but for some reason this one does not. – Will Price Mar 5 '13 at 12:23
  • Maybe the item is put into the Publish Queue but it doesn't make it out of there? Maybe no items are resolved? – Peter Kjaer Mar 5 '13 at 12:31
  • Actually I take back my previous comment about some pages being OK - it was the event system doing the autopublish - I have disabled this and now they do not publish either. There is nothing in the queue either.. Can it be a blueprint context issue? I have a BP hierarchy with Content at the top (where the component is created/edited), then Website master (where the page is created/edited), then the website itself (where the page is published). Checking the context settings it looks to be set up OK though... – Will Price Mar 5 '13 at 14:18
  • I could be related to the context, yeah. Try calling $display.getView().getPublicationId() -- that's the Publication it will try to publish the item in. – Peter Kjaer Mar 5 '13 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.