5

The presentation of this site is set up in IIS using virtual directories. So an example url would be http://somedomain/virtualDirectory/aPage.html

When I create a new page in Experience Manager, the page is successfully created and published, but the result in the browser is an improper redirect resulting in a 404. Experience Manager is trying to view the new page as http://somedomain/aNewPage.html and omitting the Virtual Directory.

Could someone please point out any configuration they feel could have been missed or that I can provide to check over?

5

Assuming that the whole of the website Publication is published out to the virtualDirectory folder (i.e. the 'Publication URL' is virtualDirectory), then you can map this in the cd_dynamic_conf.xml file (within your website's /bin/config folder and the Content Delivery Webservice) using a Publication element:

<Publication Id="95">
   <Host Domain="somedomain" Port="80" Protocol="http" Path="/virtualDirectory"/>
</Publication>

enter image description here

More details on this can be found in the Mapping Publication IDs to friendly URLs page in the online documentation (login required).

** Caution: The following note is given in this page of the online documentation:

Note that this functionality is only supported for the Java Content Delivery Web service, not the .NET Content Delivery Web service.

  • 1
    Does cd_dynamic_conf influence the publication properties (would you set both)? Also I understand the path and URL settings don't have to match (e.g. a slash for the path even when the URL differs). – Alvin Reyes Oct 18 '13 at 14:50
  • Hi Alvin. Yes, you're right - the Path and URL do not have to match. The path only influences where the content is published to on the file system. I have recently done a project with lots of Virtual Applications/Directiories and we set it in both the Publication Properties and the cd_dynamic_conf.xml – Jonathan Williams Oct 18 '13 at 15:15
4

Looking at the issue my guess would be that the Path and URL in Publication is not properly configured. When a page is created in XPM the XPM redirects to the page by using the websites base address + Publication.URL + structure groups paths (if any) + page filename + page extension. Please check you publication properties and ensure that Path and URL are appropriately saved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.