7

I have installed SDL Tridion 2013 on Windows 2008 R2 SP1 with IIS 7.5 on AWS environment, and followed every step as mentioned in the installation manual. But after successfull installation I am not able to login to the CMS from the browser as it is not accepting the username and password (We have tried with credentials of “MTS User” and a user with administrator rights.) and it is showing the error below:

Http Error 401.1 - Unauthorized. You do not have permission to view this directory or page using the credentials you supplied

  • These steps i verified in coniguration and all are correct, – Nash Mar 3 '14 at 9:50
  • if i remove the Host header name then its shows different message which i mentioned below: "Access is denied for the user DomainName\Administrator" Contact your SDL Tridion 2013 administrator – Nash Mar 3 '14 at 9:58
  • Detail of the error is : System.serviceModel.faultException '1 – Nash Mar 3 '14 at 11:07
  • Are you accessing the CME from the server or from a remote machine. Are you using localhost, machine name or a full domain name. Please share more details about your tests. – Chris Summers Mar 3 '14 at 12:48
  • I am tring accessing from AWS server itself not from remote machine, i tried with localhost, IPaddress and Hostname. I am tring to access CME by using hostname and also by removing host name from the Inetmgr, and i tried logging machine AWS server with Administrator, MTSUser and with the user which having the Administrator rights but even thoughits not working. – Nash Mar 4 '14 at 6:29
3

Issue and answer

We have CMS, CDA and Database (All DBs) each on separate servers.

CMS Server Domain: " WIN-637PDJ71N4V" DB Server Domain : "WIN-IJFCS7R5DTQ"

In the trustee table, the username "xyz" (which was an administrator) was stored as "WIN-IJFCS7R5DTQ\xyz" where " WIN-IJFCS7R5DTQ " is domain name of DB server. And we were trying to login in CME using "WIN-637PDJ71N4V\xyz" as login where " WIN-637PDJ71N4V " is domain of CMS server.

In Trustee table we found this mismatch of domain in the "name" column for both “MTS” and “xyz” user. We updated the column "name" (for user "xyz") from "WIN-IJFCS7R5DTQ\xyz" to " WIN-637PDJ71N4V\xyz".

After above change in the table, it worked and we were able to login to CMS.

2

Would you like to check for the following:

  1. Are you using Integrated Mode in IIS
  2. Have a name that is mapped to the local loopback address.

Then following MSDN article may help you: http://support.microsoft.com/kb/896861

If above is not the case: your User with which is you are trying log in have read/write (as applicable) permission on all Tridion related directories including Temp folders etc.

  • If I remove the Host header name from the Virtual directory of the SDL Site then its shows different message which i mentioned below: "Access is denied for the user DomainName\Administrator" Contact your SDL Tridion 2013 administrator – Nash Mar 3 '14 at 10:02
2

I wonder if you are having a "loop back" issue: Take a look at the accepted answer on this post: Installation issue with SDL Tridion 2013 & SDL Web 8 CME not loading all items properly.

On my servers I typically disable this if I need to access them from the local server: http://www.information-worker.nl/2009/06/23/disableloopbackcheck-on-windows-server-2008/

  • Yet after following the above 2 points, CMS showing the same issue i.e Access is denied for the uset Administrator. – Nash Mar 3 '14 at 12:43
  • I just encountered the exact issue and this solution helped. I performed the steps explained in support.microsoft.com/kb/896861 (Method 1 -- adding hostname to NTML) and all working now. – Mihai Cădariu Mar 4 '14 at 1:01
  • Hello Mihai, I tried the steps which you recommend but yet its showing same error "Access is denied for user" and also i am pasting the details about the error "System.ServiceModel.FaultException`1[Tridion.ContentManager.CoreService.Client.CoreServiceFault]: Access is denied for the user WIN-637PDJ71N4V\Administrator. (Fault Detail is equal to Tridion.ContentManager.CoreService.Client.CoreServiceFault) " – Nash Mar 4 '14 at 6:13
  • Issue is resolved......i got nastly issue behind this problem....... – Nash Mar 4 '14 at 9:43
  • Wrong machine names for the accounts? Maybe you created the databases from a different machine, and it used local accounts for that server instead of the CM server? – Nuno Linhares Mar 4 '14 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.