4

I am getting following error while editing a component -

/WebUI/Models/TCM54/Services/general.svc/SaveItem failed to execute. STATUS (400): Bad Request Bad Request

Bad Request - Invalid Verb


HTTP Error 400. The request verb is invalid.

Though, other user is able to edit the same component with no errors.

Please suggest what could be the reason.

  • try clearing cache – Raj Kumar Jun 18 '14 at 11:12
  • 1
    That error is returned if your browser sent a different verb (GET, POST, PUT, etc.) than IIS accepts for that request. In this case (save), I think it needs to be POST. I'm not sure why your browser might do that, but it could be an extension or something interfering with the request. Normally I'd say maybe someone fiddled with the settings in IIS, but then everyone would be getting the same error. Since they're not, it seems to be something with your machine/browser. – Peter Kjaer Jun 18 '14 at 11:22
  • I tried clearing browser's cache as well but that didn't work. Not sure if this has something to do with browser/extension as the issue didn't appear earlier when i tried to do same task for same schema component. – Stark Jun 18 '14 at 12:50
  • Most browsers will show you the request headers for the price of an F12 and a couple of clicks. – Dominic Cronin Jul 19 '14 at 7:37
  • Do you have this issue in Chrome's Incognito Mode? (ctrl + shift + n to open a new one) If it's only one browser, and only one user, it may have more to do with that browser than something in Tridion. may – paceaux Aug 18 '14 at 14:32
0

We faced the same issue in Chrome browser (version 36 and 37). The issue was resolved in version 38.

Please update your Chrome browser to latest stable version 38 and try again. This should resolve the issue.

0

I had a very similar error recently, that only came to light following an upgrade from Tridion 2013 GA to SP1.

The message that I was seeing was:

HTTP 400 - Bad Request (Request header too long)

The problem was that the one user in question was a member of a large number of Active Directory Groups. The solution to this was to increase the MaxFieldLength and the MaxRequestBytes registry keys on the IIS server, as described in the following Microsoft KB articles:

Although not exactly the same error that you are seeing, some sources seem to suggest that the cause of your 'Invalid verb' issue could include:

Improperly demarcated requests in the HTTP stream altered what the server interprets as the "verb"

and that this may be caused

If the users have heavy Domain Group membership which come up with complicated Kerberos tokens

If the issue is related to the Domain Groups that your user is listed in, then this would explain why the same issue is not being encountered by your colleague.

You may want to look in to the two KB articles listed above.

Alternatively, if you are using IIS6, then you may want to look in to the following Microsoft hotfix (again, related to the Domain Groups that a user in a member of): Http.sys rejects requests that contain separator characters

  • 1
    Thanks for explaining it so detailed, but, the problem came out to be with browser. I am getting this issue in Chrome specifically and not in any other browser. Though, i use chrome most of the time , not sure , how to resolve this for chrome. I am using the latest version of chrome browser. – Stark Jun 18 '14 at 13:44
  • No problem. If the issue is appearing in Chrome only, then you may want to update your question with that information. It may help you get to the answer faster! In the mean time, you may want to check your browser settings against those in the online docs and ensure that any Chrome Extensions are disabled. – Jonathan Williams Jun 18 '14 at 14:36
0

I had similar issue on chrome some time back on 2011. You can try following from top to bottom

  1. Clearing cache/cookies, reopening it worked for me
  2. Try chrome in Incognito mode (disabling all the add-ons)
  3. try “ipconfig /flushdns” on command prompt
  4. Check various solution on this link
  5. Can you compare request headers(working vs non working) using fiddler?
  6. try some previous stable version from below link, until Google release new version with fix. http://www.oldapps.com/google_chrome.php

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.