3

I have Razor Mediator 4 Tridion 1.3.3.1 installed on Tridion 2013 SP1 with a single publisher.

When I attempt to publish a page template, it fails in the publishing queue. The error message shown is,

The configuration file has been changed by another program. (C:\apps\sdl\cm\config\Tridion.ContentManager.config)

I definitely don't have the config file open in any editors. I did edit it, after installation, to modify adminUser attribute in the <razor.mediator > node. But I've never had this issue in the past. If I attempt to repair my razor mediator installation, it removes the value from the adminUser attribute, and then Razor doesn't work.

I have restarted Com+, IIS, Tridion Services, and the app pools numerous times.

  • 1
    Have you restarted the com+? – user219 Nov 3 '14 at 7:26
  • I have restarted IIS, the app pool, the Tridion site in IIS, Tridion Services, and Com+ – paceaux Nov 3 '14 at 7:48
  • usually this kind of error gets resolved as @jarnohenneman mentioned. do you have multiple publishers setup? – Raj Kumar Nov 3 '14 at 8:06
  • nope, just a single publisher. – paceaux Nov 3 '14 at 8:43
  • Razor doc says: "3.) Once installed, restart the Tridion Content Manager COM+ Package, the Tridion Publisher service, and Template Builder (if it’s open)." if any of these does not work, then box restart can be tried. – Raj Kumar Nov 3 '14 at 9:42
2

This error typically happens when you don't restart the machine after an installation that requires a restart. If you reboot the machine as requested, the error should go away.

  • thank you. I'd restarted everything individually (Com+, Tridion Services, IIS). But when I restarted the machine, it worked fine. – paceaux Nov 7 '14 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.