2

I am facing a weird problem. My website is using SDL Tridion 2013, and has Site Edit enabled. I also see the Grey Boxes with the locks for each of the items on my pages, once I click on the "SDL Tridion" tab on my webpage to enter Experience Manager. But once I unlock them, my page contents are not editable as I would expect them to be.

For example, i am not getting any 'Format tab" fro text editing or the list of images to choose from when I unlock an image for editing.

Is there anything I am missing? Where do I start looking? Any help would be really appreciated.

4

We had the wrong Publication ID in the SiteEdit_Config. Now its been corrected and problem solved.

3

Unfortunately, there are quite a few moving parts within Experience Manager (the new name for SiteEdit - The inline editor for SDL Tridion).

Problems like this are often something within the configuration, infrastructure or templating. However, before you begin to embark on an indepth investigation, I'd recommend that you check some of the basics. For example:

  1. Does your user have the necessary Rights and Permissions to edit the Page and Components within the CMS?
  2. Are the items that you are hoping to update checked-out by anyone else?
  3. Are the items in Workflow? (This would prevent them from being editable)
  4. Does your operating system and browser meet the prerequisites?
  5. Can you update this content within the normal Content Management Explorer (CME) interface?
  6. Have you tried using another browser / machine?
  7. Can other users update the content using Experience Manager (and the CME)?
  8. Are you getting any errors within the Message Centre?

If the problem still persists, and it's none if these things, then you'll need to trace the Experience Manager communication through the system. These posts should give you (or your technical team) some pointers:

  1. Nuno's answer to Continously Update Preview alert on SDL Tridion UI 2012
  2. Troubleshooting the SDL Tridion Experience Manager with Session Preview
  • Thanks Jonathan, I have checked and my problem is not really giving any error messages...After I click on the lock and select "Edit this component everywhere" I am not able to edit the content. Not sure exactly what configuration error would cause that. – user1245 Dec 2 '14 at 10:02
  • @user1245 When I say 'configuration', I am referring to system configuration, rather than something on the editor's machine. For example, this could be the location of the OData endpoint (specified on the Publishing Target), or the configuration of the CMS URL (normally set in the the templating code configuration). If it's none of the items above then I'd recommend tracing things through the steps outlined in Nuno's answer here: stackoverflow.com/a/10802033/197993 – Jonathan Williams Dec 2 '14 at 10:17
  • 1
    Thanks a lot Jonathan. We had the wrong Publication ID in the SiteEdit_Config. Now its been corrected and problem solved. – user1245 Dec 2 '14 at 11:14
  • @user1245 That's great news. Thanks for the update. Could you self-answer this question with the solution to help anyone else that comes across this problem too, please? – Jonathan Williams Dec 2 '14 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.